[test] airo : first WPA-PSK support

Dan Williams dcbw at redhat.com
Mon Feb 6 16:56:29 EST 2006


On Mon, 2006-02-06 at 21:23 +0100, matthieu castet wrote:
> Hi,
> 
> Dan Williams wrote:
> > I can help out with the mpi350 if you'd like.  However, most of the code
> > for the MPI350 should be exactly the same as with the PCMCIA version of
> > the card.  They share just about everything except for the bus type.
> > (unless I'm wrong?)
> There are some differences for RX and TX code. Search for FLAG_MPI. But 
> this should'nt be really hard to add them.
> I will try to add it this weekend.
> 
> 
> > 
> > I think bits of this patch (at least the support for the WPA & RSN
> > information elements in scans) should be upstreamed as soon as possible,
> I don't know if you know well the code, but the driver can read/write 
> some data that are indexed with RID.
> The main problem is that in order to use WPA, you need to used RID 
> supported only by newer firmware.
> For example for WPA & RSN in scan you need to use a newer RID and a 
> modified struct for data storage.
> But the RID for configuration didn't change with newer firmware but 
> there are extra elements in the structure.

AFAIK anything less than 5.40.x doesn't work anyway.  The latest stuff
(5.60.x) has worked fine.  I previously had 5.30.17, which tended to
hang the card after a while.  Anyway, perhaps we require people to
update their firmware.  Not sure.

What's the minimum firmware version for WPA support?

Dan





More information about the HostAP mailing list