Hostap interface wlan0 goes down once, then it works

Gianni Costanzi gianni.costanzi at gmail.com
Thu Apr 27 14:57:48 EDT 2006


Sorry, you were right about the DHCP client.. I've told you immediately that
there was not a DHCP client because there should not be one, because I
didn't need it :) So, it was a configuration problem ;-)

Thank you,
Gianni

On 4/21/06, Jouni Malinen <jkmaline at cc.hut.fi> wrote:
>
> On Fri, Apr 21, 2006 at 01:28:01PM +0200, Gianni Costanzi wrote:
>
> > I'm using Hostap 0.4.7 with a Netgear MA401 Wireless Card (with the
> latest
> > firmware) on a 2.6.15 kernel and everything works perfectly, apart from
> a
> > problem that happens the first time I put the card in master mode: it
> works
> > perfectly, but after few minutes (less than five, usually) the access
> point
> > deauthenticates all the stations because the wlan0 interface goes down.
> If I
> > set up again wlan0, everything works without other similar problems (for
> > hours). I do not think that it is a problem related to hostap, but I'm
> > asking this to you all just in case that someone has experienced the
> same
> > problem and perhaps has solved it.
>
> Do you happen to be running a DHCP client on the interface? Couple of
> minutes could be a timeout for DHCP client and some of the
> implementations are setting the interface down if they fail to get an IP
> address..
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>



--
--------------------------------------------------------------------------------------------------------------
|  Gianni Costanzi (gianni.costanzi at gmail.com)
|       (http://ares.science.unitn.it/~gianni.costanzi/)
|
|  Gentoo Documentation Project (GDP) Member - Italian Translator
|       (http://www.gentoo.org/proj/en/gdp/)
|
|  Free Software Foundation Member #3844 (www.fsf.org)
|
|  Why GNU/Linux? (http://www.gnu.org/gnu/why-gnu-linux.html)
--------------------------------------------------------------------------------------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20060427/44d58814/attachment.htm 


More information about the HostAP mailing list