Need clarification on WPS IE support

Sam Leffler sam at errno.com
Fri Apr 14 19:48:59 EDT 2006


CHui wrote:
>> From: Jouni Malinen <jkmaline at cc.hut.fi>
>> Subject: Re: Need clarification on WPS IE support
>> Have you tried this with the wpa_supplicant version that comes with
>> FreeBSD? It has fixes in the driver_bsd.c code that are not included in
>> wpa_supplicant v0.5.2.
>>
> 
> The FreeBSD port wpa_supplicant v0.3.8 also core dump if ap_scan=2.  The
> following is the diff of FreeBSD port driver_bsd.c with v0.4.8 and v0.5.2.

	<...stuff deleted...>

What Jouni is saying is that freebsd has wpa_supplicant bundled in the 
base system for 6.x and 7.x (aka releng6 and head).  If you use that you 
will get a driver_freebsd.c that should work. If you use the version 
bundled with the system and it does not work you should really be 
posting your problem on a freebsd mailing list.  If there is something 
that is in 0.5.2 and not in 0.4.8 that you really need then please 
contact me privately so we can discuss updating the code in the base system.

As far as I know there is no freebsd "port" for wpa_supplicant (there 
used to be one but it was removed when wpa_supplicant was incorporated 
into the base system).  Likewise trying to use wpa_supplicant unchanged 
from Jouni's cvs may or may not work correctly--the freebsd support has 
been decoupled and is maintained in freebsd so that it can track freebsd 
api's w/o Jouni having to spin new wpa_supplicant distributions.  The 
same holds for hostapd.

	Sam



More information about the HostAP mailing list