Can't authenticate: WPA, RaLink 2500 (NdisWrapper), SpeedTouch 580 router

Neil Smith neil.gd at njae.me.uk
Fri Apr 14 17:22:17 EDT 2006


On Thursday 13 Apr 2006 10:25 pm, Stefan wrote:
> Hmmm the message tx_packet dropped looks strange
>
> Is :
>
> fgrep 'wlan0' /var/log/messages
>
>
> reporting encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK;
> AES/CCMP with WPA, WPA2, WPA2PSK?
>

Here you go...

Apr 13 16:12:21 temujin network: Bringing up interface wlan0:  succeeded
Apr 13 16:12:28 temujin kernel: wlan0: vendor: 'IEEE 802.11g Wireless Card.'
Apr 13 16:12:28 temujin kernel: wlan0: ndiswrapper ethernet device 
00:11:50:90:bd:f5 using driver rt2500, 1814:0201.5.conf
Apr 13 16:12:28 temujin kernel: wlan0: encryption modes supported: WEP; TKIP 
with WPA; AES/CCMP with WPA
Apr 13 18:01:21 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 13 19:00:43 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 13 19:57:37 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 13 20:56:25 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 13 21:52:43 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 14 09:34:54 temujin dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 
port 67 interval 6
Apr 14 09:34:54 temujin dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 
67
Apr 14 20:00:57 temujin dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 
port 67 interval 4
Apr 14 20:00:57 temujin dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 
67
Apr 14 20:47:05 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67
Apr 14 21:35:22 temujin dhclient: DHCPREQUEST on wlan0 to 10.0.0.138 port 67



> In addition to that, your driver version for ralink is very old, try a
> newer driver, latest schould be:
>
> ndiswrapper: driver rt2500 (Ralink Technology, Inc.,12/15/2004,
> 3.00.01.0000) loaded
> I attached the driver, as tar.gz
>

Thanks.  I'll give your update a whirl in a couple of days when I've got time 
to test it out.  I'll let you know what happens.


> If nothing works you could try the open source driver, which doesn't
> need wpa_supplicant:
>

I tried that first, but it doesn't seem to want to play with the SMP kernel 
I'm running.  

Thanks,

Neil.

-- 
Neil Smith                         Milton Keynes Roleplaying Games Club
neil.gd at njae.me.uk                             http://www.mk-rpg.org.uk
http://home.freeuk.com/wimp/  Honorary Life Member www.SADWargamers.com



More information about the HostAP mailing list