Worked for a while, but no longer

none none throw_away_2002 at yahoo.com
Thu Nov 10 19:54:10 EST 2005


I had this working (briefly), but now
it seems I can't connect again. :(

# dog /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=2

network={
        group=TKIP
        key_mgmt=WPA-PSK
        pairwise=TKIP
        proto=WPA
        psk="mypassword"
        ssid="myssid"
        }


# wpa_supplicant -Dndiswrapper -c/etc/wpa_supplicant.conf
-iwlan0 -dd

Initializing interface 'wlan0' conf
'/etc/wpa_supplicant.conf' driver 'ndiswrapper'
Configuration file '/etc/wpa_supplicant.conf' ->
'/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
ap_scan=2
Line: 5 - start of a new network block
group: 0x8
key_mgmt: 0x2
pairwise: 0x8
proto: 0x1
PSK (ASCII passphrase) - hexdump_ascii(len=16): [REMOVED]
ssid - hexdump_ascii(len=11):  [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='myssid'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Own MAC address: [REMOVED]
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Trying to associate with SSID 'myssid'
Cancelling scan request
Automatic auth_alg selection: 0x1
WPA: Set cipher suites based on configuration
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00
00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8c07 len=87
Wireless event: cmd=0x8c08 len=40
Wireless event: cmd=0x8b15 len=24
Wireless event: new AP: [REMOVED]
Association event - clear replay counter
Associated to a new BSS: BSSID= [REMOVED]
No keys have been configured - skip key clearing
Network configuration found for the current AP
WPA: Using WPA IE from AssocReq to set cipher suites
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00
00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Associated with [REMOVED]
EAPOL: External notification - portEnabled=0

EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
RX EAPOL from [REMOVED]
RX EAPOL - hexdump(len=99): 01 03 00 5f fe 00 89 00 20 00
00 00 00 00 00 00 01 4f 08 2e ef 65 b9 cf 7d 57 01 17 73 fc
b3 b8 66 20 53 d8 81
72 85 db 8f f5 4a 9a 4e a9 13 fa 1d 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 0
0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Setting authentication timeout: 10 sec 0 usec
EAPOL: Ignoring WPA EAPOL-Key frame in EAPOL state machines
IEEE 802.1X RX: version=1 type=3 length=95
  EAPOL-Key type=254
WPA: RX EAPOL-Key - hexdump(len=99): 01 03 00 5f fe 00 89
00 20 00 00 00 00 00 00 00 01 4f 08 2e ef 65 b9 cf 7d 57 01
17 73 fc b3 b8 66 20
53 d8 81 72 85 db 8f f5 4a 9a 4e a9 13 fa 1d 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 0
0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
WPA: RX message 1 of 4-Way Handshake from [REMOVED]
WPA: Renewed SNonce - hexdump(len=32): 67 85 36 e4 71 8a 31
de f6 97 2b b0 ca 4a 10 f8 b5 37 f6 a8 ce c9 3b 73 29 ca 2c
24 0f 7e 64 fe
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: EAPOL-Key MIC - hexdump(len=16): 2d d1 5b e7 07 40 4c
2c d9 9f c8 f6 08 05 7b c4
WPA: Sending EAPOL-Key 2/4
WPA: TX EAPOL-Key 2/4 - hexdump(len=137): 00 09 5b ea 31 82
00 14 a5 15 f4 8c 88 8e 01 03 00 77 fe 01 09 00 20 00 00 00
00 00 00 00 01 67 8
5 36 e4 71 8a 31 de f6 97 2b b0 ca 4a 10 f8 b5 37 f6 a8 ce
c9 3b 73 29 ca 2c 24 0f 7e 64 fe 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 2d d1 5b
e7 07 40 4c 2c d9 9f c8 f6 08 05 7b c4 00 18 dd 16 00 50 f2
01 01 00 00 50 f2 02
01 00 00 50 f2 02 01 00 00 50 f2 02
EAPOL: Port Timers tick - authWhile=0 heldWhile=0
startWhen=29 idleWhile=59
EAPOL: Port Timers tick - authWhile=0 heldWhile=0
startWhen=28 idleWhile=58
Wireless event: cmd=0x8c07 len=87
Wireless event: cmd=0x8c08 len=40
Wireless event: cmd=0x8b15 len=24
Wireless event: new AP: [REMOVED]
Association event - clear replay counter
Associated with [REMOVED]
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED

The last 36 (or so) lines just keep repeating
(with minor changes in the hex dumps). The
client seems to see the access point (and the
access point sees the client as an "attached
device"), but somehow authentication never
seems to take place. Can someone explain why
not?

Thank you very much in advancne for your help.


	
		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com



More information about the HostAP mailing list