wpa_supplicant dies?

engage engage at n0sq.us
Thu Nov 10 18:57:00 EST 2005

I'm running version 0.4.5 with a Linksys WMP54G & Linksys WRT54G router. 
Kernel 2.6.14, Mandriva 2005LE. WPA-PSK.

The problem is that the key gets turned off on the PC. When I run killall 
wpa_supplicant I get a no process killed message. So, I execute 
wpa_supplicant, iwconfig shows everything OK (AP association, key, etc). But, 
I get no route to host when I try to ping the AP. The AP is running since my 
wired connections work OK. The WMP54G has a static address & ifconfig shows 
proper configuration. I tried a network restart and still can't ping the 
router but I can ping the wireless card address. Grr, I forgot to check the 
routing tables. Anyway, a reboot gets everything working again.  I don't see 
any problems in the logs. I'm going to turn on debugging but I'm not sure if 
I'll understand the output since I'm not a security guru. Any idea as to what 
is causing this? 

So far, google hasn't provided me with an answer or a clue. Currently, I'm 
using a workaround by having cron run a script to monitor the encryption key 
- if the key is off the PC will be rebooted - not an elegant solution but it 
keeps the system running (especially when I'm away from home).

More information about the HostAP mailing list