DWL 520 E1 no longer works

Peter Harkins ph at malaprop.org
Wed Nov 9 23:02:52 EST 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I'm having serious trouble getting my DWL-520 E1 card working again
since I switched to Ubuntu, and I can't figure out why. It used to work
fine -- well, if I did a cold boot and then immediately a warm boot
before I tried to load the driver and, yes, this took a great many hours
to puzzle out. But this is the best I can get now:

$ sudo ./hostap_fw_load wlan0
Password:
Downloading primary firmware /etc/firmware/pm010102.hex
srec summary for pm010102.hex
Included file name: PM010102.HEX
Component: 0x0015 1.1.2 (primary firmware)


Verifying update compatibility and combining data:
Plugging PDR 0400 (NIC configuration): ram16=1 pci=1 (07 00)
OK.

Downloading to volatile memory (RAM).
OK.
srec summary for pm010102.hex
Included file name: PM010102.HEX
Component: 0x0015 1.1.2 (primary firmware)

ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
STAID not available (maybe running PRI-only)
ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
ioctl[PRISM2_IOCTL_HOSTAPD]: No data available
Could not read wlan PDA. This requires PRISM2_DOWNLOAD_SUPPORT definition in driver/module/hostap_config.h.

But that configuration variable was indeed compiled in when I followed
the instructions here: https://wiki.ubuntu.com//DLinkDWL520E1 I'm on
Ubuntu 5.10 with kernel 2.6.12-9-686, hostapd and hostap-source
1:0.4.2-1, and hostap-utils 1:0.4.0-1.

I'd appreciate any advice or pointers how to get this working.

Thanks in advance.


- --
Peter Harkins    -    ph at malaprop.org    -    http://malaprop.org


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: If you don't know what this is, it's OK to ignore it.

iD8DBQFDcsZra6PWv6+ALKoRAhUoAJ9SCIFQasrY6Gcf3hD9szXggy+v3wCcDLWF
MHjUgbpdS1e8ywWABlOGUmo=
=QXy9
-----END PGP SIGNATURE-----



More information about the HostAP mailing list