Host AP/hostapd/wpa_supplicant - new development release v0.4.1

Jouni Malinen jkmaline at cc.hut.fi
Mon May 23 21:36:02 EDT 2005


On Mon, May 23, 2005 at 06:29:01PM +0200, Henrik Brix Andersen wrote:
> On Sun, 2005-05-22 at 21:04 -0700, Jouni Malinen wrote:
> > New versions of Prism2/2.5/3 Host AP driver, wpa_supplicant, and
> > hostapd were just released and are now available from
> > http://hostap.epitest.fi/
> 
> The ipw_param struct of driver_ipw.c is out of sync with the one used in
> ipw2200-1.0.4, causing wpa_supplicant-0.4.1 to fail with WPA. The
> attached patch fixes it.

And this would be out of sync with the latest ipw2100 release, wouldn't
it? wpa_supplicant shares a single driver interface for ipw2x00 drivers.
In other words, I cannot apply this unless the drivers are synced or
someone can confirm that this change works with both of the drivers.

I'm not too concerned if the wpa_supplicant development branch is
temporarily out of sync with the latest driver release, but this should
not be allowed for the stable 0.3.x branch. I was planning on releasing
0.3.9 later this week and the driver_ipw changes are already in that
branch. However, this means that either the wpa_supplicant release will
be waiting for ipw2100 driver to sync up (i.e., to get a real release to
replace 1.1.0) or I'll just revert the 64-bit fixes from driver_ipw.c
for now (assuming that gets wpa_supplicant working with both ipw2100 and
ipw2200)..

Unfortunately, I do not have either ipw2100 or ipw2200 in my test setup,
so I'm depending on someone else in testing these and coming up with an
answer on whether I can release wpa_supplicant 0.3.9 with the current
changes and this extra 32-byte padding. No one seem to have done this
with 0.3.9-rc1, since that would fail in the same way with
ipw2200-1.0.4..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list