hostapd-0.3.7 with 5213 chipset (5212) and WPA-PSK fails

Beat Meier bmeier at infovia.com.ar
Mon May 23 19:50:26 EDT 2005


Jouni Malinen schrieb:

>On Mon, May 23, 2005 at 06:06:04PM -0300, Beat Meier wrote:
>
>  
>
>>But with hostapd version 0.3.7 and this card the client cannot connect 
>>to my hostapd.
>>Without authorization there is no problem.
>>I use madwifi driver date 20050311  which I compiled myself
>>    
>>
>
>I would guess you are using madwifi driver from the CVS mainline which
>does not seem to work with hostapd. The version from 'BSD' branch of the
>madwifi CVS seems to work much better with hostapd. In addition, I would
>use a CVS snapshot of hostapd, since there are couple of driver_madwifi
>specific bug fixes that were not included in v0.3.7. Alternatively, you
>can also use the 0.3.9-rc1 version from
>http://hostap.epitest.fi/releases/testing/.
>
>  
>
I have tried now the newest one of hostapd and wpa_supplicant 
(0.3.9-rc1): The same problem.
I have also used now my old linksys WPC54G with ndis driver. The same thing.
So it don't seem to be madwifi driver.

What about the psk?
I have a Passphrase say "foo&one" and ssid "bar"
I have in hostapd.conf
wpa_passphrase=foo

In wpa_supplicant.conf the output of
/usr/local/sbin/wpa_passphrase bar "foo&one"

I have also tried to insert the generated output in hostapd.conf as 
wpa_psk instead of wpa_passphrase.
Nothing works...

BTW: Why doesn't the key[3] not change even if I change wpa_passphrase? 
What is this key?
Only key[2] changes if I restart even hostapd ...

Any hints how to trace?

Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20050523/4e0ed253/attachment.htm 


More information about the HostAP mailing list