problem starting wpa with ipw2200 from init script

Andreas Fehr andreas at
Mon May 16 10:02:23 EDT 2005

On Sun, 15 May 2005, 19:38, Andreas Fehr (as AF) wrote:

>AF: is it possible to search the mailing archive? I don't know whether 
>AF: somebody else run into my problem and solved it already.
>AF: wpa_supplicant works with my Fujitsu-Siemens P7020 if I start 
>AF: wpa_supplicant once the computer has booted. 
>AF: I don't get wpa_supplicant running if I run the same wpa_supplicant 
>AF: script during bootup of the computer. Sound strange to me.
>AF: My boot sequence is as follows:
>AF: 1) start network script
>AF: 2) run iwconfig
>AF: 3) start wpa (with -w)
>AF: 4) turn on my ipw2200 card (with the switch on the notebook)
>AF: I have no connection now
>AF: 5) start the same wpa script again
>AF: Now, I have some connection to my network
>AF: Is -w the correct parameter for wpa_supplicant with this boot 
>AF: sequence? What might be wrong here?
>AF: If somebody has some information, I'll be glad for any pointer in 
>AF: the right direction.

Well, to make it more fun to debug, read the following.

As I'm able to get a wpa connection to my access point, as soon as I 
start the wpa script manually, I did some further test and guess what... 
as soon as I kill all the wpa entries from 'ps x', my wireless 
connection is even faster than before.

Sound more than strange to me. Any idea on that?

More information about the HostAP mailing list