wpa_supplicant + ndiswrapper + WPA-PSK-AP

Matti Lattu matti.lattu at helsinki.fi
Wed Mar 23 23:48:17 EST 2005


Hi there

I'm trying to access my AP (D-Link DI 714P+) which has WPA-PSK enabled. My
not-working configuration is ndiswrapper 1.1 + D-link DWL-650+, but I've
accessed the AP with Windoze + ipw2200-based card, so the AP should work.
The ndiswrappered card contacts the AP if the WPA is turned off. My
wpa_supplicant is 0.3.8.

What happens is the wpa_supplicant does not find "suitable AP" and loops
following information:

----
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
----

Someone in this list suggested that upgrading ndiswrapper helped him, but
the 1.1 is quite new (newer than his posting) and the bleeding-edge version
of ndiswrapper does not compile in my setup.

Please let me know if there is known problem or any tricks which I could
try. I've attached the relevant information.

r. Matti L

----

modprobe ndiswrapper:

Mar 24 07:38:24 debian kernel: ndiswrapper version 1.1 loaded
(preempt=no,smp=no)
Mar 24 07:38:24 debian kernel: ndiswrapper: driver airplus
(D-Link,09/08/2003,4.15.5.1) loaded
Mar 24 07:38:25 debian kernel: PCI: Setting latency timer of device 03:00.0
to 64
Mar 24 07:38:25 debian kernel: ndiswrapper: using irq 11
Mar 24 07:38:26 debian kernel: wlan0: ndiswrapper ethernet device
00:0f:3d:03:1a:f8 using driver airplus, configuration file
104C:8400:1186:3B00.5.conf
Mar 24 07:38:26 debian kernel: wlan0: encryption modes supported: WEP, WPA
with TKIP


iwconfig wlan0

wlan0     IEEE 802.11b  ESSID:off/any  
          Mode:Managed  Frequency:2.432GHz  Access Point: 00:00:00:00:00:00  
          Bit Rate:22Mb/s   Tx-Power:0 dBm   Sensitivity=0/3  
          RTS thr:4096 B   Fragment thr:4095 B   
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-100 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


iwlist wlan0 scan

wlan0     Scan completed :
          Cell 01 - Address: 00:0D:88:07:71:CE
                    ESSID:"harkkonet"
                    Protocol:IEEE 802.11FH
                    Mode:Managed
                    Frequency:2.432GHz
                    Quality:0/100  Signal level:83/154  Noise level:0/154
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Bit Rate:22Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0


cat /etc/wpa_supplicant.conf

# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=staff

#
# home network; allow all valid ciphers
network={
        ssid="harkkonet"
        scan_ssid=1
        key_mgmt=WPA-PSK
        psk="my_password"
}


wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -dd

Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'default'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=50 (from group name 'staff')
Line: 8 - start of a new network block
ssid - hexdump_ascii(len=9):
     68 61 72 6b 6b 6f 6e 65 74                        harkkonet       
scan_ssid=1 (0x1)
key_mgmt: 0x2
PSK (ASCII passphrase) - hexdump_ascii(len=9): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='harkkonet'
Initializing interface (2) 'wlan0'
Own MAC address: 00:0f:3d:03:1a:f8
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=9):
     68 61 72 6b 6b 6f 6e 65 74                        harkkonet       
ioctl[SIOCSIWSCAN{,EXT}]: No such device
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Scan timeout - try to get results
Received 186 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 186 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=9):
     68 61 72 6b 6b 6f 6e 65 74                        harkkonet       
ioctl[SIOCSIWSCAN{,EXT}]: No such device
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Scan timeout - try to get results
Received 186 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 186 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=9):
     68 61 72 6b 6b 6f 6e 65 74                        harkkonet       
ioctl[SIOCSIWSCAN{,EXT}]: No such device
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Scan timeout - try to get results
Received 186 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:0d:88:07:71:ce ssid='harkkonet' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
[^C pressed]
Signal 2 received - terminating
No keys have been configured - skip key clearing




More information about the HostAP mailing list