EAP-TLS hostapd, wpa_supplicant 0.4.1 and atheros 5212 card fails

Beat Meier bmeier at infovia.com.ar
Tue Jun 21 15:30:58 EDT 2005


Jouni Malinen schrieb:

>
>>Jun 20 20:15:51.364901: WPA: RSN IE in Beacon/ProbeResp - 
>>hexdump(len=24): *30 16 01 00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 
>>01 00 00 0f ac 01*
>>Jun 20 20:15:51.366089: WPA: RSN IE in 3/4 msg - 
>>hexdump(len=26):                       *30 18 01 00 00 0f ac 02 02 00 00 
>>0f ac 04 00 0f ac 02 01 00 00 0f ac 01 00 00*
>>    
>>
>
>madwifi driver does not implement a mechanism for synchronizing WPA/RSN
>IEs with hostapd and this can trigger the error you are seeing. This
>should really finally be fixed by providing such mechanism.. So far, the
>workaround has been in trying to make madwifi driver do whatever hostapd
>generates as the IE, but not all versions of the driver do this. Which
>version are you using here?
>
>  
>
Jouni

I'm using cvs version of madwifi-bsd-20050530 but with an older one 
there was the same problem.
Can you give me some hints about the authorization steps i.e. with which 
message you are sure the
radius client has authorized us and what if authorization fails.
Also there would be nice that there is a log message if the server is 
authenticatete (wpa_supplicant)

Where can I get info about the patch, but I think this is a very new 
version so the patch should be applied already?

BTW: What kind of help can you need with the project?

Thanks

Beat




More information about the HostAP mailing list