Compiling hostapd for madwifi on wisp-dist

mrcool at stupidgamerz.com mrcool at stupidgamerz.com
Mon Jun 20 15:22:05 EDT 2005


Hello!

I dont know which list i want to get this so I sent it to all of them...

I am trying to compile hostapd for use with an atheros card in wisp-dist.

Everything is cross-compile, of course, and I have figured all that out and
can make hostapd compile (finally).  When I first went to run hostapd, it
complained about missing libraries, I copied the libraries to the wisp
machine, and it, aparently, accepted them, now the error message is
complaining about missing glibc 2.3.  I know wisp is built on an old version
of redhat, so I think it has an older version of glib.

Is there a way to statically compile hostapd to not need the extra libraries?

I can compile hostapd for a hostap card and it will run fine on wisp without
needing any other libraries, although I dont know what particular version I
was using, it might be older.

Any ideas? 

Thanks

Jerryf



More information about the HostAP mailing list