wpa-radius not working ..

alfred hitch alfred.hitch at gmail.com
Thu Jun 9 05:04:04 EDT 2005


Hi Jouni / All,

Need your opinions / pointers on this.

EAP handshake, SSL tunnel is created and secret key is exchanged
between supplicant and radius.

But, after that I am getting MIC failures at AP (at 2nd step of 4 way
handshake ..)

Dumps show that free radius server does passes MS-MPPE keys back to AP also,

But at 2nd step (which is in a way first test of PMK between
supplicant and AP) of 4 way hand-shake it is failing. MIC failure ..

Tracing thru I find that the PMK dump on supplicant and radius are
same, yet AP it seems is dropping packet for MIC failures ?

Now, I am CLUELESS on why this should be, as my reasoning goes belows:

1)  all this is chip / driver independent code at both sides, so there
has to be something wrong in my configurations only on supplicant and
radius ..

2) because SSL was created well and messages passed, that should mean
the key supplicant has matches with radius has .. (as otherwise data
encrypted using key would have been rejected by server ??)

3) I tried a windows client to associate in same setup, same radius ,
same AP and it works .. (which has frusated me more infact now -;) )

4) WPA-PSK was working and very stable with my driver port for supplicant, 

Can someone please help me with this, on what could be wrong ..
I am attaching my supplicant side config file,

Need suggestion on these guys , please -;))

Cheers,
Alfred


PS: I have been trying to port wpa_supplicant as previosuly mentioned also
on to a connexant world radio chip and have got wpa-psk working
infact.

Now, shifting to wpa-eap I am having some issues.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: peap.conf
Type: application/octet-stream
Size: 14091 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20050609/e15f1700/attachment.obj 


More information about the HostAP mailing list