madwifi wpa 0.4.1

Shawn Adams shawn_adams at web.de
Sun Jun 5 12:19:29 EDT 2005


I have a SuSE 9.2 notebook, with a PCMCIA wireless adapter, using the
MADWIFI driver.

The card works fine with WEP 104bit, open mode, but when I configure for
WPA-PSK, the card associates, but then loses association every 10
seconds, just keeps looping. The successful auth lasts long enough to
obtain an address via DHCP, and the AP reports successful auth and
association, but the 10 seconds sure sounds like the Setting
authentication timeout: 10 sec 0 usec


Any ideas would be appreciated.

thanks in advance.



The madwifi driver:
----------------------
messages:Jun  4 18:42:17 kappa kernel: ath0: Atheros 5211:
mem=0x20800000, irq=
11
messages:Jun  4 18:42:33 kappa kernel: ath0: no IPv6 routers present
messages:Jun  5 17:58:16 kappa kernel: ath_hal: 0.9.12.5
messages:Jun  5 17:58:16 kappa kernel: ath_rate_onoe: 1.0
messages:Jun  5 17:58:16 kappa kernel: ath_pci: 0.9.4.5 (EXPERIMENTAL)
----------------------

the /etc/wpa_supplicant.conf :
-------------------------------
eapol_version=1
ap_scan=1
network={
        ssid="Test_wob_a"
        scan_ssid=0
        proto=WPA WPA2
        key_mgmt=WPA-PSK WPA-EAP IEEE8021X
        psk="xxxxxxx"
        pairwise=TKIP CCMP
        group=CCMP TKIP WEP104
}
----------------------------------


the debug looks like:

Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=12
Wireless event: cmd=0x8b19 len=12
Received 381 bytes of scan results (2 BSSes)
Scan results: 2
Selecting BSS from priority group 0
0: 00:20:d8:03:8a:bc ssid='Test_wob_a' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
   selected
Trying to associate with 00:20:d8:03:8a:bc (SSID='Test_wob_a' freq=5200 MHz)
Cancelling scan request
Automatic auth_alg selection: 0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 4 pairwise 8 key_mgmt 2
WPA: using GTK WEP104
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 05
01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
wpa_driver_madwifi_associate
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=25
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:20:d8:03:8a:bc
State: ASSOCIATING -> ASSOCIATED
Association event - clear replay counter
Associated to a new BSS: BSSID=00:20:d8:03:8a:bc
No keys have been configured - skip key clearing
Associated with 00:20:d8:03:8a:bc
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Wireless event: cmd=0x8b1a len=25
Authentication with 00:20:d8:03:8a:bc timed out.
Added BSSID 00:20:d8:03:8a:bc into blacklist
State: ASSOCIATED -> DISCONNECTED
wpa_driver_madwifi_disassociate
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE

etc...etc...loop to infinity....




More information about the HostAP mailing list