[-mm patch] include/net/ieee80211.h must #include <linux/wireless.h>

Jouni Malinen jkmaline at cc.hut.fi
Sat Jul 30 22:24:22 EDT 2005


On Wed, Jul 27, 2005 at 09:51:00PM +0200, Adrian Bunk wrote:

> gcc found an (although perhaps harmless) bug:
> 
>   CC      net/ieee80211/ieee80211_crypt.o
> In file included from net/ieee80211/ieee80211_crypt.c:21:
> include/net/ieee80211.h:26:5: warning: "WIRELESS_EXT" is not defined

> +++ linux-2.6.13-rc3-mm1-full/include/net/ieee80211.h	2005-07-22 18:38:10.000000000 +0200
> +#include <linux/wireless.h>

>  #if WIRELESS_EXT < 17
>  #define IW_QUAL_QUAL_INVALID   0x10

Wouldn't the proper fix be to just remove this backwards compatibility
code since WIRELESS_EXT is actually 18 in this tree anyway.. Is there
valid need to keep this header file compatible with older kernel
versions?

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list