driver_hermes and wpa_supplicant CVS

Jouni Malinen jkmaline at cc.hut.fi
Sat Jul 30 21:09:18 EDT 2005


On Sat, Jul 30, 2005 at 10:47:01PM +0400, Andrey Borzenkov wrote:

> > > Both contain a driver_hermes.c, but both driver_hermes.c won't work with 
> > > wpa_supplicant from current CVS
> > It may work with the CVS snapshot of the stable branch, but indeed, it
> > does not work with the latest 0.3.x versions. I fixed number of issues
> > in the driver interface code and updated all the driver interface
> > implementations in the wpa_supplicant package. However, driver_hermes.c
> > has never been submitted to the wpa_supplicant tree and its license does
> > not allow me to release a fixed version.
> 
> would it be possible to make patches available? Unfortunately orinoco does not 
> support WPA on hermes so using Agere drivers is almost the only choice :(

If someone can convince Agere to release the driver_hermes.c and
required header files under compatible open source license, I would be
open to adding it to the wpa_supplicant distribution and even converting
it to use the new driver API. Alternatively, the driver could be
modified to use the new version of Linux wireless extensions (v18) which
would allow driver_wext.c to be used as is without requiring driver
specific changes in wpa_supplicant.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list