ioctl[IPW2100_IOCTL_WPA_SUPPLICANT]: Operation not supported

Pedro Ramalhais ramalhais at serrado.net
Wed Jan 26 18:13:12 EST 2005


On Wed, 2005-01-26 at 22:00, Richard.Griffiths at windriver.com wrote:
> I'm having no success trying to use wpa_supplicant with an ipw2100 using
> LEAP. The interface works fine on a non-authenticating AP. I've made
> sure that the driver's Makefile has the CONFIG_IEEE80211_WPA=
> $(CONFIG_IEEE80211_CRYPT) enabled.
> On FC3 2.6.10_741, I've install ipw2100 v. 1.0.2 with the set_security
> patch. I've tried several versions of wpa_supplicant including 0.3.6.
> I would appreciate any help getting this resolved.

The error message is probably caused by the ipw2100 driver not having
WPA support compiled in. Maybe the ipw2100 is in the initrd image and
the system is loading that one instead of the one you compiled. Try
using the ./unload and ./load scripts in the ipw2100 driver source.
-- 
Pedro Ramalhais <ramalhais at serrado.net>




More information about the HostAP mailing list