...it works with madwifi, but not ipw2200?

Ian McDonald imcdnzl at gmail.com
Mon Feb 14 15:51:07 EST 2005


If you go back through the list archive (see URL at the bottome) you
will see there are issues with IPW2200 and WPA and some suggestions.
Also issues with non-broadcast of SSIDs as well so you will have
double fun!!


On Mon, 14 Feb 2005 17:15:09 -0330, Greg Baker <gbaker at cs.mun.ca> wrote:
> Hey guys..  Just wondering if there's any weirdness with the ipw2200 drivers?
> After successfully setting up my own wireless using wpa_supplicant 0.3.8, I
> decided to try to set up my friend's...
> 
> The APs that we use here do not broadcast the SSID, and I think that may be
> where the problem is coming from.  His keeps saying "No suitable APs found".
> 
> I can do an "iwlist eth1 scan" and see the APs, but their SSIDs are showing as
> hidden. Any comments?  Does this card fully support WPA+TKIP?
> 
> Here's our config file:
> 
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=wheel
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> network={
>         ssid="stu"
>         scan_ssid=1
>         key_mgmt=WPA-EAP
>         eap=PEAP
>         pairwise=TKIP
>         group=TKIP
>         identity="gbaker"
>         password="...."
>         phase1="include_tls_length=1 peapver=0"
>         phase2="auth=MSCHAPV2"
> }
> 
> Also, one other thing, whenever I get an IP from DHCP, it messes up my
> hostname.  Does anyone know the switch to dhclient that will let me keep my
> own hostname?
> 
> Thanks,
> Greg
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>



More information about the HostAP mailing list