ioctl[SIOCSIWPMKSA]: Operation not supported

Jouni Malinen jkmaline at cc.hut.fi
Tue Apr 12 00:16:29 EDT 2005


On Mon, Apr 11, 2005 at 09:32:03PM +0200, Henrik Brix Andersen wrote:

> #define SIOCSIWPMKSA    0x8B36          /* PMKSA cache operation */
> 
> WE-18 PMKSA cache operation. Shouldn't wpa_supplicant compile for WE17
> when that is all the kernel supports?

That would be of somewhat limited use since WE-17 does not include
support for WPA. In theory, driver_wext.c could be made to work in
limited mode (i.e., no WPA) when used with drivers that do not support
WPA or with WE-17 or older.

Since you seemed to be using ipw2200 driver, I would have assumed the
ipw driver interface would have been used. Did v1.0.3 of the driver
already add support for WE-18?

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list