wpa_supplicant error when trying to use EAP-PEAP/GTC

Jouni Malinen jkmaline at cc.hut.fi
Tue Oct 12 09:32:29 EDT 2004


On Tue, Oct 12, 2004 at 03:23:48PM +0200, Henrik Brix Andersen wrote:

> I was told by Pedro Ramalhais in #ipw2100 on freenode that the patch
> would not work with wpa_supplicant-0.2.5 since it relied on a
> misbehavior of wpa_supplicant-0.2.4 that had been corrected in 0.2.5.

Oh, I did not know about that kind of "feature".. Getting some details
of this might be useful if any help is needed for getting this to work
with 0.2.5.

> The patch applies fine (with offsets in a couple of hunks). I have been
> unable to locate the original patch online but I have a copy of it in my
> portage overlay at
> http://dev.gentoo.org/~brix/files/overlay/net-wireless/wpa-supplicant/files/wpa-supplicant-0.2.4-ipw2100.patch.gz
> 
> Are there any plans to include the patch in wpa_supplicant?

I have been waiting for someone to submit that patch for inclusion into
development branch. I don't have ipw2100 card myself, so I have not been
testing this myself. If there is a known issue with the current patch,
it sounds like that should be resolved first. Anyway, I'm ok with adding
this to wpa_supplicant once someone tells me it is ready for this..

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list