Kernel panic using hostapd

Arnaud kwabbernoot at wanadoo.nl
Sun May 23 22:15:48 EDT 2004


Hi Jouni,

I now run the 0.2.1 version for some time now without a problem. I 
also have disabled hotplug when hostapd starts and that helps 
against the boot panic. Now I will wait if it will happen again 
while running for some time.

If it will panic again I will send the panic with the symbols resolved.

Thanks for your respond.
Regards,
Arnaud


Jouni Malinen wrote:
> On Sat, May 15, 2004 at 06:02:04PM +0800, Kwabbernoot wrote:
> 
> 
>>When I started to use hostapd (0.2.0) sometimes my kernel panics. 
>>The program on the stack is doing a NULL pointer deref. I have some 
>>photo's of my console taken with my camera. I have seen hotplug 
>>doing it a few times but sometimes it's an other program.
> 
> 
>>I tried hostapd -dd but no output, so I tried a strace and the 
>>kernel paniced this moment:
>>
>><snip>
>>munmap(0x40014000, 4096)                = 0
>>socket(PF_INET, SOCK_DGRAM, IPPROTO_IP) = 3
>>ioctl(3, 0x8be0
>>^*****panic*****^
> 
> 
> That does not look complete.. I would need to get the full kernel panic
> message with symbols resolved (e.g., with ksymoops) in order to be able
> to find out what happened.
> 



More information about the HostAP mailing list