Can't seem to 'make' it work (ha ha)

Keith Redfield kredfield at airsurfwireless.com
Thu Jun 24 00:14:56 EDT 2004


OK, I'm stoopid..
 
I have openssl and got a clean make/make install..fine.
 
But when I try to make wpa_supplicant with MSCHAP and PEAP  I get complaints :
 
[root at bridge1 wpa_supplicant-0.2.3]# make
cc -MMD -O2 -Wall -g -I../driver/modules -I../utils
-I../hostapd -DCONFIG_DRIVER_HOSTAP -DIEEE8021X_EAPOL
-DEAP_PEAP -DEAP_MSCHAPv2 -DEAP_TLS_FUNCS
-DCONFIG_WIRELESS_EXTENSION   -c -o config.o config.c
In file included from config.c:22:
sha1.h:6:25: warning: openssl/sha.h: No such file or
directory
In file included from config.c:25:
eap.h:5:25: warning: openssl/ssl.h: No such file or
directory
eap.h:6:25: warning: openssl/err.h: No such file or
directory
In file included from config.c:25:
eap.h:103: error: parse error before "SSL_CTX"
eap.h:103: warning: no semicolon at end of struct or
union
make: *** [config.o] Error 1
 
 
I did put a symbolic link from OPENSSLHOME/include/openssl in wpa_supplicant root since that's where the files it's expecting seem to live..but no change so is there some PATH directive I'm missing? Where is it expecting openssl libs to be?
 
I'm a linux noobie and can't really follow C so have mercy...I did search a few months of the archives and no joy, but feel free to point me.
 
THX
 
-Keith
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20040623/999ec97b/attachment.htm 


More information about the HostAP mailing list