Help configuring DWL-520 Rev.B1

James B Hiller jhiller at visi.net
Mon Jun 21 23:49:34 EDT 2004


Hi.

In the subject, you reference Rev B1 of the card, but in the body you
reference Rev E1 and E.  Which one do you have?

jbh


On Mon, 21 Jun 2004, Cesar Reyes Mardones wrote:

> Hi
> I load the hostap_pci module and the card didn't get started. I saw that 
> someone has problem with the DWL-520 Rev.E1 and load a "firmware" (Subject: 
> Please, help with the dwl520rev.E firmware!!! ). I am using hostap 0.1.3 
> that doesn't have the command hostap_fw_load. Is that my problem?? Have I 
> think in install the development driver and load the same firmware that 
> Marcos used? Please help me out here... any experience with this card would 
> help me a lot.
> 
> I have wireless tools 26, linux kernel 2.4.18-20 (original RH9 kernel), 
> before I compiled the HostAP dirver, I install the linux-wlan-ng and the 
> card is working great with that in Managed Mode. 
> 
> 
> César Reyes M.
> Electronic Engineering Student
> Universidad de La Frontera, Temuco - CHILE
> 
> 
> PS: This is the output of some commands that may be useful.
> 
> 
> [root at fc69 root]# lspci -v
> 00:08.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset 
> (rev
> 01)
>         Subsystem: D-Link System Inc DWL-520 Wireless PCI Adapter
>         Flags: bus master, medium devsel, latency 32, IRQ 9
>         Memory at df6ff000 (32-bit, prefetchable) [size=4K]
>         Capabilities: [dc] Power Management version 2
> 
> [root at fc69 root]# dmesg
> hostap_crypt: registered algorithm 'NULL'
> hostap_pci: 0.1.3 - 2004-02-08 (Jouni Malinen <jkmaline at cc.hut.fi>)
> divert: allocating divert_blk for wlan0
> hostap_pci: Registered netdevice wlan0
> prism2_hw_init: initialized in 0 ms
> wlan0: NIC: id=0x8013 v1.0.0
> wlan0: PRI: id=0x15 v1.0.7
> Could not get RID for component STA	<-------- I think HERE is the Poblem
> wlan0: Failed to read STA f/w version - only Primary f/w present   <--------
> wlan0: Intersil Prism2.5 PCI: mem=0xdf6ff000, irq=9
> 
> [root at fc69 root]# iwconfig
> lo        no wireless extensions.
>  
> eth0      no wireless extensions.
>  
> wlan0     IEEE 802.11-DS  ESSID:"test"
>           Mode:Master
>           Encryption key:off
>           Link Quality:0  Signal level:0  Noise level:0
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>  
> [root at fc69 root]# ifconfig wlan0
> wlan0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
>           Interrupt:9 Memory:d08ff000-d0900000
> 
> 
> 
> --
> Universidad de La Frontera (http://pinhue.ufro.cl)
> 
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
> 




More information about the HostAP mailing list