Unable to read wireless statistics using the 0.1.2 drivers

Bradley Chapman kakadu_croc at yahoo.com
Mon Jan 26 11:35:18 EST 2004


Hi everyone!

I have successfully compiled and installed the HostAP 0.1.2 driver against a 2.6.1
kernel on my Gateway 600S laptop. My wireless card is a Prism3-based Linksys WPC11
with primary firmware 1.0.1 and station firmware 1.8.0.

I have noticed that when I try to read the output of /proc/net/wireless, or access
the wireless statistics using the gkrellm-wireless plugin, I get this message in the
dmesg:

wlan0: hostap_get_wireless_stats() called while atomic - skipping signal quality
query

The driver detects my card like this:

cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x1c0-0x1cf 0x378-0x37f 0x3c0-0x3df
0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.1.2 - 2003-11-02 (Jouni Malinen <jkmaline at cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
hostap_cs: Registered netdevice wlan0
prism2_hw_init: initialized in 194 ms
wlan0: trying to read PDA from 0x007f0000: OK
wlan0: NIC: id=0x801b v1.0.0
wlan0: PRI: id=0x15 v1.1.1
wlan0: STA: id=0x1f v1.8.0
prism2: wlan0: operating mode changed 3 -> 2
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus: BSSID=00:06:25:18:24:49
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus: BSSID=44:44:44:44:44:44
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus: BSSID=44:44:44:44:44:44
hostap_crypt: registered algorithm 'WEP'
wlan0: LinkStatus=2 (Disconnected)
wlan0: LinkStatus: BSSID=44:44:44:44:44:44
wlan0 unsupported ioctl(0x8947)
wlan0: LinkStatus=1 (Connected)
wlan0: LinkStatus: BSSID=00:0d:29:17:ca:67

I was able to read the statistics using the orinoco_cs drivers, so I think this
is a misconfiguration or a bug in the 0.1.2 drivers.

What should I check?

TIA

Brad

=====


__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!
http://webhosting.yahoo.com/ps/sb/



More information about the HostAP mailing list