WDS with older firmware AP's?

Pavel Roskin proski at gnu.org
Mon Feb 16 17:12:01 EST 2004


On Mon, 16 Feb 2004, Jason Straight wrote:

> I'm just starting to tinker with WDS, and have a question. I've found that
> it's recommended to have newer firmware to use the 4 address mode on the
> hostap client, is it necessary to have newer firmware on the AP you are
> joining up with?

As I understand, the WDS support is only needed on the access points.
Clients (you mean stations, right?) don't use 4-address packets, so they
don't need new firmware for that purpose.  Intersil station firmware 1.5.0
or newer is needed for an access point running HostAP to support WDS.  If
the other access point doesn't run HostAP it still needs to support WDS.
Whether it needs firmware upgrade is irrelevant to HostAP - you should see
the manual and possibly the site of the vendor.

-- 
Regards,
Pavel Roskin



More information about the HostAP mailing list