modprobe hostap_pci locks up machine

Ian Goldberg linux at
Tue Dec 7 11:32:36 EST 2004

On Tue, Dec 07, 2004 at 08:04:55AM -0800, Ka-Hing Cheung wrote:
> > Wow.  Off and on again.
> > 
> > That worked.  Once.  I was able to modprobe hostap_pci, but when I tried
> > to load the firmware, it crashed.  Now, even after off-and-ons, the
> > modprobe hostap_pci crashes once again.
> That's strange, are you sure that you loaded the right firmware? I
> would also try to switch to a different PCI slot just to make sure
> it's not a bad slot (I've run into this once on another machine, took
> me a whole week to setup that PCI modem...).

OK, we tried a different PCI slot, and, what do you know?  The crashes
are gone.  Now, we've got a new problem:

I do:

iwconfig wlan0 mode managed
iwconfig wlan0 essid DUKE

But when I check it with iwconfig, I get:

wlan0     IEEE 802.11b  ESSID:""
          Mode:Managed  Access Point: 00:00:00:00:00:00   Bit Rate:2Mb/s
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/70  Signal level=-73 dBm  Noise level=-73 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Note there's no ESSID.  I can't seem to get any ESSID to appear there in
Managed mode at all.  :-(

I'm using pm010102.hex and rf010803.hex as my firmware.


   - Ian

More information about the HostAP mailing list