modprobe hostap_pci locks up machine

Ian Goldberg linux at paip.net
Tue Dec 7 10:53:26 EST 2004


On Mon, Dec 06, 2004 at 10:41:16PM -0800, Ka-Hing Cheung wrote:
> I had the same problem. First, I think hotplug would try to load the
> orinoco module for the card, so make sure that you blacklist orinoco
> from hotplug. Second, if the machine does lock up, make sure that you
> power off the computer and then start it up again, otherwise if you do
> a reboot it would lockup when you do a modprobe.
> 
> When I first setup my machine, I installed hostap after I played with
> the orinoco driver, and it kept locking up whenever I modprobe the
> hostap driver. I almost gave up until I found that, upon doing a cold
> reboot, everything works.

Wow.  Off and on again.

That worked.  Once.  I was able to modprobe hostap_pci, but when I tried
to load the firmware, it crashed.  Now, even after off-and-ons, the
modprobe hostap_pci crashes once again.

Feh.

Any more thoughts?

   - Ian



More information about the HostAP mailing list