Senao SL-2511CD Ext2 (Yang-Hwee TAN)

Kieran Murphy daffy at daffy.za.net
Mon Jun 23 02:00:39 EDT 2003


Hi,

I managed to find instructions on how to fix this problem on 
www.pccard.co.uk
It seems that these bridges have problems assigning IRQ's

I fixed the problem by specifying PCIC_OPTS="irq_mode=0" in me 
/etc/pcmcia.conf (for debian) using the i82365 PCIC driver.
I use pcmcia-cs and not the kernel pcmcia support.
Other hints are to put the PCMCIA bridge in the PCI Bus Master slot and 
force it to use a pci IRQ by adding pci_irq_list=<irq>,<irq> in 
PCIC_OPTS line. My understanding is there must be 2 irq's in the list.

I hope this helps.


Yang-Hwee TAN wrote:

>Hi,
>
>i'm not sure what causes this no irq errors either.
>recently, about a month ago, i bought a Richoh pcmcia 
>adapter as well, and have the same error. at first i 
>thought it was bios. i change the installation on 
>another system with different bios, it didn't work too.
>both m/boards did have pci bus v2.2 or higher.
>
>happen that the richoh card is valid for a refund, 
>hence i went to get a refund for incompatible reason. 
>i realised this Richoh cards seesm to have been revised 
>and unable to be used for Wireless cards on Linux.
>And it works well on Windows. I find it really strange, 
>but i didn't have time to debug and figure more out of 
>it at that time.
>
>May be others have similar experience with any recently 
>bought Richoh adaptor cards, please share if you encountered 
>and fixed it.
>
>
>thanks,
>yanghwee.
>
>- - -
>On Fri, 20 Jun 2003 17:16:14 +0200
>amalvido <amalvido at gts.tsc.uvigo.es> wrote:
>
>  
>
>>Thanks dear Yang-Hwee.
>>
>>Your help it's very useful to me. I go forward, but I jey have some 
>>problems. Now I have next error message  whit dmesg:
>>
>>hostap_crypt: registered algorithm 'NULL'
>>hostap_cs: hostap_cs.c 0.0.0 2002-10-12 (SSH Communications Security 
>>Corp, Jouni Malinen)
>>hostap_cs: (c) Jouni Malinen <jkmaline at cc.hut.fi>
>>hostap_cs: setting Vcc=33 (constant)
>>hostap_cs: CS_EVENT_CARD_INSERTION
>>prism2_config()
>>hostap_cs: setting Vcc=33 (from config)
>>Checking CFTABLE_ENTRY 0x01 (default 0x01)
>>IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
>>io->flags = 0x0046, io.base=0x0000, len=64
>>hostap_cs: RequestIRQ: Resource in use
>>prism2_release
>>: card already removed or not configured during shutdown
>>release - done
>>prism2_detach
>>hostap_free_data: ap has not yet been initialized - skip resource freeing
>>
>>The Ricoh PCMCIA-PCI adapter isn't on control panel irq list, but it 
>>appears in lspci.
>>In pcmcia file in /etc/sysconfig/ directory I wrote:
>>PCMCIA=yes
>>PCIC=i82365
>>PCIC_OPTS="irq_mode=1"
>> It's this fine.
>>
>>Thanks to All for your responses.
>>
>>
>>
>>_______________________________________________
>>HostAP mailing list
>>HostAP at shmoo.com
>>http://lists.shmoo.com/mailman/listinfo/hostap
>>    
>>
>_______________________________________________
>HostAP mailing list
>HostAP at shmoo.com
>http://lists.shmoo.com/mailman/listinfo/hostap
>
>
>  
>



More information about the HostAP mailing list