prism2 routing table issues

Travis Read travisr at rave.iinet.net.au
Wed Jan 29 01:56:46 EST 2003


I cracked it,

Turns out an extry in cron had a script that was destroying the route
table. I've since fixed it and hostap is working fine again :-)

Kind regards,

------------------------------------------------------------------------------
Travis Read
iiNet Senior Support       | Ph +61 8 9214 2222 Fx +61 8 9214 2211
travisr at staff.iinet.net.au | Level 6, Durack House, 263 Adelaide Terrace
------------------------------------------------------------------------------

" there is a war going on, it's not about who has the most bullets,
         it's about who controls the information " - SNEAKERS

On Tue, 28 Jan 2003, Jouni Malinen wrote:

> On Wed, Jan 29, 2003 at 11:52:57AM +0800, Travis Read wrote:
>
> > I'm finding the the hostap driver and the orinoco driver both work fine
> > for a while. But after an unknown time period the route table goes away:
>
>
> > eth1: MAC address 00:60:1D:1B:F9:AD
>
> > wlan0: dropped received packet from 00:60:1d:1b:f9:ad with no ToDS flag
> > (type=0x02, subtype=0x00)
> > wlan0: RX status=0x2000 (port=0, type=1, fcserr=0) silence=0 signal=81
> > rate=20 rxflow=0; jiffies=1715
> >    FC=0x0008 (type=2:0) dur=0x0000 seq=0x0000 data_len=68
> >    A1=ff:ff:ff:ff:ff:ff A2=00:60:1d:1b:f9:ad A3=00:00:00:00:00:00
> > wlan0: prism2_close
>
> Your Orinoco card seemed to have sent a broadcast data frame that the
> Host AP driver dropped since it was adhoc frame. This should not cause
> such problems that you described. Something set wlan0 interface down
> after this. I don't think there is any code in Host AP driver that could
> do this, so I would assume that it was some unknown user space program.
>
> How do you configure IP addresses for wlan0 and eth1? Could you have,
> e.g., DHCP client in the background setting interfaces down after some
> timeout?
>
> > after it ways prism2_close the entire route table for pcmcica devices goes
> > away and I'm left with:
>
> Setting the interface down will remove all routing entries using that
> interface, so this is quite expected.
>
> > I'm not 100% sure this is a problem with the hostap driver but I'm still
> > lost and can't figure out whats broken. What am I missing? Is it the
> > firmware?
>
> I don't think this is Host AP driver, firmware, or hardware issue. It
> sounds more like something setting interfaces down for some odd reason.
> I can only come up with DHCP client as an example for now, but there
> might be other programs doing it, too.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>




More information about the HostAP mailing list