card initialization+firmware problems

Elias Tsigoyannis a99-4427 at
Sat Aug 30 15:16:26 EDT 2003

After reading Jun Sun's mini-HOWTO on flashing Intersil Prism chipsets ( ) I
found out that the latest Primary Firmware for platform 8003 is 0.3.0 and
the latest secondary firmware is 1.5.6.
I was wondering whether somebody could get the latest intersil drivers from
and extract the flash version for the secondary firmware 1.7.1 for platform
8003.  I have seen some instructions
at but I
think that they just extract the ram
version of the firmware ( I want the flashable version). I don't have linux
installed so I am unable to follow these

I have found somewhere in the web the file r1010701.hex which I attach in my
e-mail. Can somebody tell me
what this is? I think that this is the ram version of secondary firmware
1.7.1 but can someone test it? (I don't
know to download ram firmwares using windows).

I also found at a
file that describes the differences
between every secondary firmware version for PCI cards from 1.0.0 to 1.4.9.
Does anyone know if the same ones
apply for PCMCIA cards,too? Does anyone have the corresponding files until
secondary version 1.7.4? What are
the differences between the primary and the tertiary versions?

Finally, I would like to say something that has to do with my problem, which
is stated below as well as in another
message in the same thread. I read in the web that setting RID createIBSS
(FC81) to 1 works only on firmwares
after 1.3.6 (I think). I have tried it setting to 0, too (since I am
interested only in ad hoc mode) however I had no
success. The same problems continued appearing. Is there a possibility that
the problem doesn't have to do with the
secondary firmware but with something else? (eg. primary firmware, tertiary
firmware, etc) Can someone help me?

Thanks again,
Elias Tsigoyannis

----- Original Message -----
From: "Elias Tsigoyannis" <a99-4427 at>
To: <hostap at>
Sent: Saturday, August 30, 2003 7:31 PM
Subject: card initialization+firmware problems

> Hello to everybody!
> Can somebody explain to me the initialization process of a prism2 card?
> I use the winupdate programme to upgrade the firmware of my card and it
> says:
> Platform:    8003
> Primary Firmware:    0.3.0
> Station (Secondary) Firmware: 0.6.2
> At first, I would like to ask if there is a primary firmware that is newer
> than 0.3.0 for my card. I have seen
> primary firmwares with number 1.1.0, but they are for different platforms
> (800a,etc). Is there such a firmware
> for my card? I have also found secondary firmware 1.5.6 that can be
> to my card. Does anyone have station firmware
> 1.7.x for platform 8003?
> Anyway, I want to use this card in ad hoc mode. At first, I was using
> firmware 0.6.2. I issued the "initialize command" without
> any problems, however I noticed that when I put the value 0 to RID
> (0xFC00) as Intersil Prism
> Driver's Manual says, even though I got a link status message that said
> "Connected", immediately after I issued the "enable command" (for channel
> 0),
> the RID PortStatus (0xFD40) had the value 6 (Connected to WDS). I read
> Intersil's FAQs and found out
> that the old manual said that old firmwares should use value 4 for RID
> PortType. I tried that and the result was
> that I didn't get a Link Status message, after the "enable command", but
> PortStatus had the value 3 (Connected to IBSS). The problem either way
> is that I can neither send any frames nor is my IBSS detected by any
> analyzers that I've used (I have 2 pcs. In one
> of them I run the wireless network analyzer and at the second one I create
> the IBSS. Both of them have Intersil Prism HWB3163-EVAL
> wireless cards).
> Anyway, I tried upgrading the firmware to 1.4.9 and 1.5.6 and now I face a
> different problem. Although I can't put value 4 to
> PortType (because PortStatus gets a value not specified by Intersil's
> manual), if I put value 0 to PortType, then PortStatus gets
> the value 2 (Searching for initial connection) and remains there. Since I
> always put value 1 to RID createIBSS (FC81) that means
> that the card should either search for an ESS/IBSS or create an IBSS,
> a while the RID PortStatus should change to 3
> (Connected to IBSS). However it doesn't.
> Does anyone know any firmware that operates according to Intersil's Driver
> Programmer's manual?
> I want the following events to occur:
> 1)I issue the initialize command
> 2)I set RID PortType to 0 (or 4...however please tell me which one I
> use)
> 3)I set RID createIBSS to 1 (join ESS or create/join IBSS)
> 4)I configure DesiredSSID,OwnSSID,OwnName,Channel
> 5)I issue the enable command for channel 0
> 6)I get a link status interrupt that says that I am connected and the
> PortStatus RID has the value 3 (Connected to IBSS)
> If I have understood something wrong and that's not the correct
> initialization sequence please inform me..
> Thanks in advance,
> Elias Tsigoyannis
> _______________________________________________
> HostAP mailing list
> HostAP at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: r1010701.hex
Type: application/octet-stream
Size: 163277 bytes
Desc: not available
Url : 

More information about the HostAP mailing list