Failed flash. Prism2.5 Senaeo 2511cd plus

Jouni Malinen jkmaline at cc.hut.fi
Wed Aug 6 00:04:53 EDT 2003


On Tue, Aug 05, 2003 at 10:44:36PM -0500, Jerry wrote:

> tried to flash my Senaeo card to 1.7.4, failed.  I was pumped by the recent posts about flashing to the most recent firmware, so i gathered what i thought i needed to flash to 1.7.4.
> Latest CVS, and prism2_srec, firmware files pk010101.hex, and sf010704.hex.  The card is a NCCID:  800c, so, to the best of my knowledge  those were (are) the proper firmware files for this card.  It was in a PLX adapter, and ram dl to 1.5.6 at the time of the "incedent".

What where the firmware versions (PRI and STA) in the flash? Did you try
downloading both PRI and STA images with one prism2_srec command? I
don't think I have tested flash download when running RAM-downloaded
image, so that is a possible reason for problems.

> Well, without -f to test it gave what looked like a common output, mentioned something about a few small things that looked like they were more warnings than anything else (sorry, it was remote, i dont have that mesg at this point if i can find it in a log somewhere ill post it), and it ended with 'OK' which i incorrectly took to mean that this was ok to use.

Getting the exact list of those few small things would be useful for
finding out what went wrong. That OK is supposed to mean that the
firmware image is indeed suitable for the card.

> After many second thoughts (but not enough ;) i put the -f in.  flash failed.

Did you happen to have the error message anywhere? Both from prism2_srec
and the driver ('dmesg')? They would be quite useful in figurin out what
happened.

> Please, no flames, just some guidance.   I have been searching the archives (more recent stuff) and have all sorts of firmware, winupdate (2), and even the dos util (i havent tried this yet, but i will).  Windows will find the card and make the "beep beep" sounds, but it has a blat on device managler (driver installs win98), both the winupdates do nothing but make the cursor go to the hourglass for a few seconds then nothing, doenst even install, aparently. (0.5, and 0.7 winupdates).

So, Windows fails to initialize the driver. What about Linux (with the
latest CVS snapshot of Host AP driver)? Does hostap_plx report "no
device found"? What do you get in kernel log ('dmesg')?

> Do i need special hardware to fix this?

Prism2.5 should have software controlled Genesis mode, so no special
hardware should be needed. If the primary is still OK and able to start
without STA firmware, Host AP driver should be able to initialize the
card. If this is not the case, you would need to initialize the card by
first downloading initial firmware to RAM using Genesis mode. Host AP
driver does not support this, so you would probably need to use the DOS
tools for this.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list