Still no ap action going on here :( help please.

Linux Rocks! linux at rocksolidnetworks.com
Thu Dec 12 18:25:40 EST 2002


Hi,
	Im still not having any luck with any linux modules for my Proxim RangeLan-DS 
PC Cards. Im really unsure what Im doing wrong. 
	Im currently using Kernel 2.4.20, hostap-2002-10-12, my firmware version is 
0.8.3. Wireless Tools Version 26 (compiles with WE 15).  
	Im compiling stuff on my main workstation (not the machines using hostap) as 
the laptops that are using hostap suck (p-120/24meg/300, 720mb hard disks)
	The hostap module is using the standard stuff in the 2.4.20 kernel source, 
(yes, WE 14...)
	Ive compiled the orinoco_cs module using the same 2.4.20 kernel source, tried 
it against hostap, and the windows software w/no luck.
	Ive tried hostap_cs in all 3 modes (master, ad-hoc, managed) against the 
windows laptop with no luck (on the windows computer Ive tried 
Infrastructure, Ad-hoc, and 802.11 Ad-hoc). No matter what I do, I cannot 
seem to get anything to associate! 
	Before my big laptop hard disk died, I had tested the cards with 2 windows 
laptops... they worked fine, so Im confident that there arent hardware 
problems.
	This is what Im doing:
	cd to hostap-2002-10-12
	make pccard
	make install_pccard
	Then I copy the files that make install_pccard copys to a directory, tar them 
up, and ftp them to the laptop. I then make the directorys and copy those 
files to the exact same locations on the laptop (yes, I used copy/paste to 
make sure I get that right).
	NOTE: I havnt edited any files in the hostap source, I just make them. I get 
no errors or problems compiling, I get no errors loading the modules. dmesg 
looks fine, lsmod looks fine. make install_pccard does give me depmod errors, 
but only Im not using it on the workstation... When I run depmod -a on the 
laptop, it gives no errors. 
	Others on this list say my dmesg/iwconfig look fine, but Ill include them 
below again to see if anyone can find a problem.

iwconfig:
Warning: Driver for device wlan0 has been compiled with version 14
of Wireless Extension, while this program is using version 15.
Some things may be broken...

wlan0     IEEE 802.11-b  ESSID:"blah"  
          Mode:Master  Frequency:2.422GHz  Access Point: 00:60:B3:6F:63:CC  
          Bit Rate:11Mb/s   Tx-Power:-6 dBm   Sensitivity=1/3  
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root at lapdance:~# iwconfig --version
iwconfig  Version 26
          Compatible with Wireless Extension v15 or earlier,
          Currently compiled with Wireless Extension v15.

wlan0     Recommend Wireless Extension v13 or later,
          Currently compiled with Wireless Extension v14.


<bottom section of dmesg containing hostap stuff...>

cs: IO port probe 0x0a00-0x0aff: excluding 0xa68-0xa6f 0xaa0-0xaa7 0xaf8-0xaff
cs: memory probe 0x0d0000-0x0dffff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: hostap_cs.c 0.0.0 2002-10-12 (SSH Communications Security Corp, 
Jouni Malinen)
hostap_cs: (c) Jouni Malinen <jkmaline at cc.hut.fi>
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: ignoring Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
hostap_cs: Registered netdevice wlan0
prism2_hw_init()
prism2_hw_config: initialized in 9089 iterations
wlan0: NIC: id=0x8002 v1.0.0
wlan0: PRI: id=0x15 v0.3.0
wlan0: STA: id=0x1f v0.8.3
wlan0: defaulting to host-based encryption as a workaround for firmware bug in 
Host AP mode WEP
wlan0: LinkStatus=2 (Disconnected)
wlan0: prism2_open

<hostap_cs.conf (part regarding my card)>

   manfid 0x0126, 0x8000
   bind "hostap_cs"
#   module "hostap_cs" opts "essid=any channel=6 ignore_cis_vcc=1"


# Optional configuration parameters for hostap_cs.o
# module "hostap_cs" opts "channel=6 essid=any ignore_cis_vcc=1"
 module "hostap_cs" opts "channel=3 iw_mode=3 essid=blah ignore_cis_vcc=1"
# module "orinoco_cs" opts "ignore_cis_vcc=1"

Note: I need the ignore_cis_vcc=1 or I get a bunch of nasty errors!

Thanks in advance, Jamie

-- 
No microsoft products were used to produce this message.
EUG-LUG Mailing List:
http://mailman.efn.org/cgi-bin/listinfo/eug-lug




More information about the HostAP mailing list