Hello, <br><br>I'm trying to compile hostap-driver-0.4.9 on a CentOS 4.4 machine. I installed&nbsp; the kernel-devel package so I could build the module.<br><br>The KERNEL_PATH ?= /lib/modules/$(KVERS)/build seems to be correct and when I type 'make' it seems as though the compile seems to starts but here is the output.
<br><br>&nbsp;# make<br>make -C /lib/modules/2.6.9-42.0.2.EL/build SUBDIRS=/root/hostap-driver-0.4.9/driver/modules \<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; MODVERDIR=/root/hostap-driver-0.4.9/driver/modules modules<br>make[1]: Entering directory `/usr/src/kernels/2.6.9-
42.0.2.EL-i686'<br>&nbsp; CC [M]&nbsp; /root/hostap-driver-0.4.9/driver/modules/hostap.o<br>In file included from /root/hostap-driver-0.4.9/driver/modules/hostap.c:116:<br>/root/hostap-driver-0.4.9/driver/modules/hostap_ap.c:21: warning: `MODULE_PARM_' is deprecated (declared at include/linux/module.h:552)
<br>/root/hostap-driver-0.4.9/driver/modules/hostap_ap.c:26: warning: `MODULE_PARM_' is deprecated (declared at include/linux/module.h:552)<br>/root/hostap-driver-0.4.9/driver/modules/hostap_ap.c:31: warning: `MODULE_PARM_' is deprecated (declared at include/linux/module.h:552)
<br>/root/hostap-driver-0.4.9/driver/modules/hostap_ap.c:36: warning: `MODULE_PARM_' is deprecated (declared at include/linux/module.h:552)<br>In file included from /root/hostap-driver-0.4.9/driver/modules/hostap.c:118:<br>
/root/hostap-driver-0.4.9/driver/modules/hostap_ioctl.c:4121: error: unknown field `get_wireless_stats' specified in initializer<br>/root/hostap-driver-0.4.9/driver/modules/hostap_ioctl.c:4121: warning: initialization makes integer from pointer without a cast
<br>/root/hostap-driver-0.4.9/driver/modules/hostap.c: In function `hostap_setup_dev':<br>/root/hostap-driver-0.4.9/driver/modules/hostap.c:942: error: structure has no member named `wireless_data'<br>make[2]: *** [/root/hostap-
driver-0.4.9/driver/modules/hostap.o] Error 1<br>make[1]: *** [_module_/root/hostap-driver-0.4.9/driver/modules] Error 2<br>make[1]: Leaving directory `/usr/src/kernels/2.6.9-42.0.2.EL-i686'<br>make: *** [2.6] Error 2<br>
<br><br>And then it dies on this. I tried an older version of hostap 0.3.9 and I get the same errors. <br><br>Is there something that I can do to get this to compile.<br><br>Thank you for any help.<br><br>Romeo<br>