Can't get hostapd to work with madwifi

Stijn Tintel stijn at
Fri Sep 8 11:10:01 EDT 2006

Kim Johnsson wrote:
> Hi,
> I have successfully installed madwifi 0.9.2 on my slackware 10.1 
> computer. I've tested it and it works fine. I do however want 
> encryption, which is why I downloaded hostapd. The problem is, whenever 
> I try to start it, it give me this output:
> -----
> root at Athena:/files/temp/hostapd-0.4.9# hostapd /etc/hostapd.conf
> Configuration file: /etc/hostapd.conf
> ioctl[SIOCSIWMODE]: Invalid argument
> Could not set interface to master mode!
> madwifi driver initialization failed.
> rmdir[ctrl_interface]: No such file or directory
> -----

You need to create a VAP in master mode, as you cannot change the mode 
of an existing VAP in madwifi(-ng). Read and for more info on this.

> I've tried several configurations, including ones found on the net which 
> the posters claim should work. The latest one I tried is this:

Since your madwifi VAP isn't in master mode, hostapd will not start, 
even if your configuration is OK. If after creating a VAP in master 
mode, hostapd still wont start, please read

> I've googled a lot about this, but I haven't found anything useful. I 
> apprieciate any help you can give me.

IMO, for problems with madwifi, you should look at 
before trying google, the wiki contains a whole lot of useful information...

> /Kim


More information about the HostAP mailing list