Problem with hostapd-0.3.11 " Invalid IEEE 802.1X configuration (no EAP authenticator configured)"

Jouni Malinen jkmaline at
Mon Sep 4 11:01:51 EDT 2006

On Mon, Sep 04, 2006 at 05:29:12PM +0530, rajat.dudeja at wrote:

> I am using the hostapd-0.3.11 on one of a linux machine running kernel :
> 2.6.5-1.358.
> when I run: hostapd -dd ./hostapd.conf,  I get these errors:
> Configuration file: ./hostapd.conf
> Invalid IEEE 802.1X configuration (no EAP authenticator configured).
> 1 errors found in configuration file './hostapd.conf'

You will either need to enable the internal EAP server or configure an
external RADIUS authentication server to be able to use IEEE 802.1X.

> My linux machine is not having any wireless Lan Card, I am trying to use
> hostapd using the wired ethernet.
> NB: I also have tried running the latest hostapd-0.4.9 and in that I am
> getting the errors :
> Configuration file: ./hostapd.conf
> ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
> Could not enable hostapd mode for interface wlan0

You must set driver=wired and set the correct interface in hostapd.conf
for this to work.

Jouni Malinen                                            PGP id EFC895FA

More information about the HostAP mailing list