What to do now?

Linux Rocks! linux at rocksolidnetworks.com
Sun Jan 12 00:06:56 EST 2003

On Saturday 11 January 2003 06:10 pm, Jouni Malinen wrote:
: On Sat, Jan 11, 2003 at 04:28:20PM -0800, Jamie wrote:
: > FFFF=FWID=0003C0.HEX<00><00><INTERNAL STAT<00><00>
: Hmm.. That "<INTERNAL STAT" looks odd.. This position is usually
: reserved for station firmware identifier and I have never seen such
: identifier.. Maybe card manufacturer has used some special station
: firmware image(?) Everything else in hostap_diag output looked OK.
Hmm... Maybe something to investigate. 
: Yes, everything seems to be OK as far as card initialization and
: configuration is concerned. Unfortunately, I cannot see anything that
: would indicate what is causing the problems. You could also enable all
: RX/TX packets dumps in the driver with 'iwpriv wlan0 dump 7' (or
: 'utils/prism2_param wlan0 dump 7' if you are not using wireless tools
: version 25 or newer).
I think Im using 25 or 26. (ive tried to make sure everything was the most 
current (I did notice after adding the 2.4.20 source, I ended up with WE 14 
instead of 15...)
I tried and got this:
root at lapdance:~# iwpriv wlan0 dump 7
<mapping sub-ioctl dump to cmd 0x8BE0-7>

: Next step would be to setup a third host as a wireless sniffer and make
: a dump of all frames sends by the station and the AP.. This should be
: able to confirm whether the AP is sending beacons and is responding to
: station's probe request.
Hrmmm... problems! I only have 2 cards. I have tried Network stumbler, and 
aerosol on the windows laptop, but they dont seem to work.
I have another linux hard drive (its pretty small... ) with hostap, and 
orinoco modules on it, but since I dont have it working in linux, how could I 
use a sniffer with it?

This Is what I have:
3 Laptops
2 PCMCIA wireless NIC's (Proxim RangeLan DS)
Hard Drives (hard drives are interchangeable)
1 340 meg Windows98
1 720 meg (Slackware Linux)
1 340 Meg (OpenBSD 3.0) (does detect the card, but I dont know how to 
configure it..., or if it will work if I did...)
1 340 Meg Slackware Linux 
1 workstation running low on diskspace (with no wireless equipment, but 
connected via ethernet..)

I just downloaded the current cvs. maybe I can try it later...

any ideas what I can do with what I have? At the LUG meetings, there is an AP, 
Ive connected to it via windows, it works (but I cant mess with thier AP...)


: > Ill try to get the current cvs, could you remind me how/where?
: Easiest way is to download a snapshot of the CVS tree from
: http://hostap.epitest.fi/. Direct link for this is
: http://hostap.epitest.fi/cgi-bin/viewcvs.cgi/hostap/hostap.tar.gz?tarball=1

No microsoft products were used to produce this message.
EUG-LUG Mailing List:

More information about the HostAP mailing list