Weird problems with hostapd and 802.1x

Luca Salgarelli salga at
Sun Oct 27 19:17:39 EST 2002


I am trying to make 802.1x work with the HostAP driver and hostapd, but
I am having some weird problems.

When hostapd tries to enable 1x support in the driver, the
'PRISM2_PARAM_IEEE_802_1X' ioctl call fails with an OPNOTSUPP error.

The weird part is this: I am pretty sure that the first few times I
tried the setup, it initialized correctly in 1x "testing" mode (-xm). It
started suddenly to show this behavior after a few times I restarted
hostapd, without, as far as I remember, that I changed anything.

The second weird thing is that enabling 1x support in the driver with
iwpriv works fine. So much that for now I have substituted the calls to
the relevant ioctl's in hostapd.c with system calls to iwpriv, and now
it starts up correctly.

Has anyone any idea of what might be wrong? (Details about my setup

Also, this might be related or not, but I also have another problem with
hostapd: using xsupplicant on my client, I can see hostapd receiving the
EAPOL-start packet. It then says that it is sending a Request-Identity
packet back. However, xsupplicant doesn't receive it, and I can't see it
with tcpdump either, although I do see the EAPOL-Start sent by the
client. Any idea about what's wrong here as well?

Could the firmware of my Prism card be the problem? Note that the AP and
my client talk to each other happily the Prism card is in non-1x mode.

This is my setup:

AP: DWL-520 card, running in open mode.
        NIC: id=0x8013 v1.0.0
        PRI: id=0x15 v1.0.5
        STA: id=0x1f v1.3.4
    HostAP 2002-10-12
    kernel 2.4.20-pre11 with wireless_ext v15, but I also tried a stock
kernel 2.4.19 (wireless ext v13) with the same (bad) results.

Client: latest CVS version of xsupplicant, stock kernel 2.4.18 RH 8.0,
Orinoco card. 

Thanks in advance for your help.

More information about the HostAP mailing list