<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.6000.16788" name=GENERATOR></HEAD>
<BODY>
<DIV><FONT face=Arial size=2>
<DIV>
<DIV dir=ltr align=left><SPAN class=963124420-16012009><FONT face=Arial 
size=2>Attempting to connect from a wireless client to an Access Point running 
hostapd and madwifi with WPA2 with Pre-shared key (PSK) or with EAP.&nbsp; 
Hostapd (with -dd) emits following message on the access point: (see below for 
versions of stuff, had this working with earlier Linux kernel).&nbsp; Also, the 
ath0 interface is included in a bridge br0 on the access 
point.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2>------------------------------------------------------------------------------------</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>hostapd -dd 
/etc/hostapd/hostapd.conf.wpa_psk</FONT></SPAN></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Configuration file: 
/etc/hostapd/hostapd.conf.wpa_psk<BR>ctrl_interface_group=0<BR>Configure bridge 
br0 for EAPOL traffic.<BR>madwifi_set_iface_flags: dev_up=0<BR>br0: port 2(ath0) 
entering disabled state<BR>madwifi_set_privacy: enabled=0<BR>BSS count 1, BSSID 
mask ff:ff:ff:ff:ff:ff (0 bits)<BR>SIOCGIWRANGE: WE(compiled)=22 WE(source)=13 
enc_capa=0xf<BR>ath0: IEEE 802.11 Fetching hardware channel/rate support not 
supported.<BR>Flushing old station entries<BR>madwifi_sta_deauth: 
addr=ff:ff:ff:ff:ff:ff reason_code=3<BR>ioctl[IEEE80211_IOCTL_SETMLME]: Argument 
list too long<BR>madwifi_sta_deauth: Failed to deauth STA (addr 
ff:ff:ff:ff:ff:ff reason 3)<BR>Could not connect to kernel 
driver.<BR>Deauthenticate all stations<BR>madwifi_set_privacy: 
enabled=0<BR>madwifi_del_key: addr=00:00:00:00:00:00 
key_idx=0<BR>madwifi_del_key: addr=00:00:00:00:00:00 
key_idx=1<BR>madwifi_del_key: addr=00:00:00:00:00:00 
key_idx=2<BR>madwifi_del_key: addr=00:00:00:00:00:00 key_idx=3<BR>Using 
interface ath0 with hwaddr 00:80:48:55:96:aa and ssid&nbsp;<SPAN 
class=494594418-27012009>'TEST_SSID'</SPAN><BR>madwifi_set_ieee8021x: 
enabled=1<BR>madwifi_configure_wpa: group key cipher=3<BR>madwifi_configure_wpa: 
pairwise key ciphers=0x8<BR>madwifi_configure_wpa: key management 
algorithms=0x2<BR>madwifi_configure_wpa: rsn 
capabilities=0x0<BR>madwifi_configure_wpa: enable WPA=0x3<BR>WPA: group state 
machine entering state GTK_INIT (VLAN-ID 0)<BR>GMK - hexdump(len=32): 
[REMOVED]<BR>GTK - hexdump(len=16): [REMOVED]<BR>WPA: group state machine 
entering state SETKEYSDONE (VLAN-ID 0)<BR>madwifi_set_key: alg=CCMP 
addr=00:00:00:00:00:00 key_</FONT></SPAN><SPAN class=963124420-16012009><FONT 
face=Arial size=2>idx=1<BR>madwifi_set_privacy: 
enabled=1<BR>madwifi_set_iface_flags: dev_up=1<BR>ath0: Setup of interface 
done.<BR>l2_packet_receive - recvfrom: Network is down<BR>Wireless event: 
cmd=0x8b1a len=21<BR>Wireless event: cmd=0x8c03 len=20</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2>------------------------here's the 
error---------------------------<BR>ath0: STA 00:21:29:ea:c9:54 IEEE 802.11: 
associated<BR>&nbsp; New STA<BR>ioctl[unknown???]: Invalid 
argument<BR>madwifi_process_wpa_ie: Failed to get WPA/RSN IE<BR>Failed to get 
WPA/RSN information element.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2>------------------------------------------------------------------------<BR>Wireless 
event: cmd=0x8c03 len=20<BR>ath0: STA 00:18:39:11:8a:41 IEEE 802.11: 
associated<BR>&nbsp; New STA<BR>ioctl[unknown???]: Invalid 
argument<BR>madwifi_process_wpa_ie: Failed to get WPA/RSN IE<BR>Failed to get 
WPA/RSN information element.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2>-----------------------------------------------------------------------------------</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Running Debian Linux 
on ARM PXA-270.&nbsp; Originally had this working on kernel v2.6.16.60.&nbsp; 
Kernel config was from ARM board manufacturer.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Wireless is Atheros 
AR5212 on mini-PCI&nbsp; </FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Madwifi-ng version 
0.9.4 (svn v3354)</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Original working 
config: -- worked for both PSK and EAP modes.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Debian kernel 
v2.6.16.60</FONT></SPAN></DIV><FONT face=Arial><FONT size=2>Wireless extensions 
was v1<SPAN class=494594418-27012009>9</SPAN></FONT></FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>hostapd 
v0.5.5</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>madwifi 
0.9.4</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Had to update kernel 
to v2.6.24.7 for additional hardware feature and now I get above error when 
client attempts to connect</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>Debian kernel 
v2.6.24.7</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>W<SPAN 
class=494594418-27012009>ireless extensions</SPAN> v22</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial><FONT size=2>hostapd 
v0.5.11<SPAN class=494594418-27012009> (rebuilt on new 
kernel)</SPAN></FONT></FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial><FONT size=2>madwifi 
0.9.4&nbsp;<SPAN class=494594418-27012009>(rebuilt on new 
kernel)</SPAN></FONT></FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>(also previously 
tested with hostapd v0.5.5 before trying 0.5.11, but same 
result.)</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>wireless client in 
both cases is a Linksys USB WUSB54GSC running on a WinXP sp2 
box.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>error is comming 
from ioctl call in driver_madwifi::set80211priv for op-code 
IEEE80211_IOCTL_GETWPAIE</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>This is defined in 
madwifi code /net80211/ieee80211_ioctl.h as SIOCDEVPRIVATE+4.&nbsp; 
SIOCDEVPRIVATE is defined in linux/include/sockios.h as 0x89F0.&nbsp; I was able 
to confirm that when the above error occurs the op-code is 0x89F4.&nbsp; 
</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial size=2>At this point, I'm 
stumped.&nbsp;&nbsp;Is the linux kernel missing something hostapd or madwifi are 
expecting?&nbsp; Wireless extensions problem?&nbsp; Any help would be 
appreciated.</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2>Mike</FONT></SPAN></DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=963124420-16012009><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV></DIV></FONT></DIV></BODY></HTML>