<div>Hi, all.</div>
<div>I am a novice at 802.1x.</div>
<div>I met&nbsp;some very strange problems between supplicant and authenticator.</div>
<div>&nbsp;</div>
<div>Following is my hostapd conf:</div>
<div>interface=ath0</div>
<div>bridge=br0</div>
<div>driver=madwifi</div>
<div>ssid=MyAP</div>
<div>ieee8021x=1</div>
<div>eapol_version=2</div>
<div>eap_message=hello</div>
<div>eap_reauth_period=3600</div>
<div>own_ip_addr=<a onclick="return top.js.OpenExtLink(window,event,this)" href="http://127.0.0.1/" target="_blank">127.0.0.1</a></div>
<div>auth_server_addr=<a onclick="return top.js.OpenExtLink(window,event,this)" href="http://192.168.2.254/" target="_blank">192.168.2.254</a></div>
<div>auth_server_port=1812</div>
<div>auth_server_shared_secret=mypassword</div>
<div>acct_server_addr=<a onclick="return top.js.OpenExtLink(window,event,this)" href="http://192.168.2.254/" target="_blank">192.168.2.254</a></div>
<div>acct_server_port=1813</div>
<div>auth_server_shared_secret=mypassword</div>
<div>&nbsp;</div>
<div>And&nbsp;at supplicant terminal,&nbsp;this is my wpa_supplicant conf:</div>
<div>network={</div>
<div>&nbsp;&nbsp;&nbsp; ssid=&quot;MyAP&quot;</div>
<div>&nbsp;&nbsp;&nbsp; key_mgmt=IEEE8021X</div>
<div>&nbsp;&nbsp;&nbsp; eap=MD5</div>
<div>&nbsp;&nbsp;&nbsp; identity=&quot;testuser&quot;</div>
<div>&nbsp;&nbsp;&nbsp; password=&quot;testpassword&quot;</div>
<div>}</div>
<div>&nbsp;</div>
<div>Then, I type: wpa_supplicant -Dmadwifi -iath0 -cmyconf.conf</div>
<div>it displays &quot;CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully&quot;</div>
<div>&nbsp;</div>
<div>At that time, I ping from supplicant to other host in the same&nbsp;bridge,</div>
<div>AP can receive these ARP packets and forward to other bridge port,</div>
<div>and the host that I ping to also can respond the ARP packet,</div>
<div>AP also can send these packets out from its interface.</div>
<div>But,</div>
<div>My supplicant can receive&nbsp;any these&nbsp;packets!!!!!!</div>
<div>I wonder why this situation&nbsp;occure.</div>
<div>&nbsp;</div>
<div>Every time&nbsp;few minutes after I receiving success EAP packet,</div>
<div>screen shows:</div>
<div>Authentication with 00:19:5b:ec:9a:70 timed out.</div>
<div>CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys</div>
<div>&nbsp;</div>
<div>then, my association with AP is broken.</div>
<div>&nbsp;</div>
<div>Does someone also meet the problem?</div>
<div>Is there any problems in my configuration file?</div>