WPA_Supplicant 2.1 bgscan won't populate scan_results

matthew stanger stangerm2 at gmail.com
Fri May 29 14:27:21 EDT 2015


Jouni,

Thanks, still very new to wpa but that gets me straight!

On Fri, May 29, 2015 at 11:32 AM, Jouni Malinen <j at w1.fi> wrote:

> On Fri, May 29, 2015 at 11:04:17AM -0600, matthew stanger wrote:
> > First time post, so I hope my question is in line. I'm using
> WPA_Supplicant
> > 2.1 with Wext driver, on a Linux 2.6.27 kernel. The issue is that bgscan
> > fails to populate 'scan_results' other than the network that
> wpa_supplicant
> > is currently connected to. I can provide logs, where I preform a manual
> > scan via wpa_cli. It produces ~30 'scan_results' which you can then see
> > fall off/expire. After that, the bgscan triggers but scan_results show
> only
> > 1/32 networks, which is the network which is currently connected to?
> After
> > that the bgscan never causes the 'scan_results' list to be repopulated.
> If
> > I run 'iwlist mlan0 scan' however, the bgscan will populate with scan
> > results instantly? Any idea's on maybe something I'm doing wrong or have
> > setup incorrectly?
>
> Which driver are you using? Please also note that the bgscan
> functionality was not really designed to work with WEXT (i.e., you
> better use nl80211 for this) and the goal of bgscan is to find roaming
> candidates within the same ESS, so while it may not be by design, not
> updating results for other networks would be proper behavior.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20150529/edebd47f/attachment.htm>


More information about the HostAP mailing list