EAP-TLS not successful

Premraj Sundaram premraj.sundaram at gmail.com
Thu Jun 11 17:50:58 EDT 2015


Hi Jouni,
Thanks for your response.
I was using JRadiusSimulator GUI as the client.
The same client works with FreeRadius and returns Access-Accept.

I would prefer to make hostapd work, because my next step is to do EAP-AKA.

EAP: EAP entering state INTEGRITY_CHECK
EAP: EAP entering state METHOD_RESPONSE
SSL: Received packet(len=456) - Flags 0x00
SSL: Received packet: Flags 0x0 Message Length 0
SSL: Fragment overflow
EAP-TLS: CONTINUE -> FAILURE

The above lines make me thinking whether it could be an SSL issue.


Thanks,
Premraj

On Thu, Jun 11, 2015 at 1:27 PM, Jouni Malinen <j at w1.fi> wrote:

> On Thu, Jun 11, 2015 at 11:34:31AM -0700, Premraj Sundaram wrote:
> > Have configured hostapd as RADIUS Server and trying to do EAP-TLS.
> > I have been unsuccessful in getting this right. Following are the logs.
> > Is it due to some configuration which I am missing.
>
> What do you use as the EAP-TLS peer in this test? It looks like that
> device has incorrect EAP-TLS implementation.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20150611/cec91d23/attachment-0001.htm>


More information about the HostAP mailing list