Unable to connect to WPA2-Enterprise since 2.4-r1: WPA_ALG_PMK bug?

Jouni Malinen j at w1.fi
Wed Jul 8 15:38:55 EDT 2015


On Wed, Jul 08, 2015 at 08:26:19PM +0100, David Woodhouse wrote:
> On Wed, 2015-07-08 at 22:11 +0300, Jouni Malinen wrote:
> > Write a clear debug log entry and also send it to control interface 
> > monitors when it looks likely that this case has been hit.
> 
> I'll test these patches later; thanks. In the meantime, this touches on
> something else I was hoping to look at... is this failure mode actually
> supposed to be reported coherently to NetworkManager, and then to the
> user?

Unfortunately, it is not. Some of the EAP operation events are still
available only through the (non-D-Bus) control interface and this new
message is in that category.

> It is extremely suboptimal at the moment that any form of failure is
> mostly just silent. I haven't yet worked out where the real fault lies.

Agreed. Someone would need to define a suitable extension to the D-Bus
events to make this information available from wpa_supplicant and
matching changes in NetworkManager to be able to display this. Some of
the related events are available as D-Bus signals (e.g., as far as TLS
certificate validation steps are concerned), but I don't think there is
any generic event signal that would allow wpa_supplicant to make NM
display something all the way to the user in a reasonable manner today.
 
-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list