wpa_supplicant fails to connect with EAP

Jouni Malinen j at w1.fi
Tue Aug 18 12:14:01 EDT 2015


On Tue, Aug 18, 2015 at 10:57:21AM -0500, Dan Williams wrote:
> On Tue, 2015-08-18 at 09:55 -0500, Kenny Pearce wrote:
> > Thanks! The MTU was set to 1280 (I don't know why). Changing it to 1500
> > fixed the problem.
> 
> Also, NetworkManager should look at the MTU of the wifi interface and
> make sure the fragment size is lower than that.  Although one issue here
> is that if the MTU gets set via DHCP, we have a chicken + egg issue
> since the MTU would be changed long after we've sent the config to the
> supplicant.

It should be fine for wpa_supplicant to change its internal default for
every EAP handshake or at least for each connection if the value is not
set in the configuration file. That said, if this does indeed get set as
part of the DHCP exchange, it would really need to be for each EAP
handshake and not just connection and that sounds a bit excessive (while
still doable, if there is a real use case needing something like this).
I guess one could even subscribe to some event messages indicating MTU
changes and update fragmentation threshold dynamically, but this is
getting to the level of complexity that may be even harder to justify
taken into account that I have somewhat limited understanding on benefit
of doing MTU changes during an association..

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list