Creating an access point with wpa_supplicant via dbus interface

Marlon Smith marlon.smith10 at gmail.com
Thu Apr 23 17:49:47 EDT 2015


Oh thanks, yes I should have indicated that I've set these values:

ssid: mynetwork
key_mgmt: NONE
wep_key0: 12345
mode: 2
frequency: 2412
ap_scan: 2

I'll run it with the debug arguments and let you know what I get.

On Thu, 2015-04-23 at 16:28 -0500, Dan Williams wrote:

> On Thu, 2015-04-23 at 13:57 -0700, Marlon Smith wrote:
> > Hi everyone,
> > 
> > I've written an application that allows a user to connect to a wifi
> > network.  The application uses the dbus interface of wpa supplicant, and
> > it works great.
> > 
> > I need a way for the user to be able to configure the system as an
> > access point as well.  I've tried setting mode=2 and frequency=2412 but
> > with no luck.  I'm thinking I might have to instead use hostapd, but
> > that becomes a pain because hostapd kills wpa_supplicant when it starts
> > and has no dbus interfaces that I can find.
> 
> You also want to set the Interface object's 'ap_scan' variable to '2',
> same as for adhoc mode.
> 
> But beyond that, it should just work if the driver supports AP mode.
> What errors are you getting?  Can you share some supplicant debug logs?
> You can run the supplicant with "-dddtu" arguments alone and that should
> enable the dbus interface and provide verbose debugging output.
> 
> Dan
> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20150423/1ec0fdab/attachment.htm>


More information about the HostAP mailing list