question regarding use_monitor for nl80211 driver

Izoard, CedricX cedricx.izoard at intel.com
Mon Sep 29 12:17:37 EDT 2014


Hi,

We're facing issue with full mac driver, when creating p2p groups.

The driver reports it support ap_sme but not probe command nor tx data status, so use_monitor is set to 1 in wpa_driver_nl80211_capa.
Then when setting up the AP for the p2p group, because of (device_ap_sme=1 and use_monitor=1) the supplicant doesn't register handler for management frame and then action frames sent to the p2p group are not processed.

On kitkat baseline, there is patch that force use_monitor to 0 if driver support WPA_DRIVER_FLAGS_OFFCHANNEL_TX (commit aec9e647dab45c87511f822f6f9468800ec6f3b1 "AOSP: nl80211 use_monitor hack")
Since L-dessert is using upstream supplicant this patch is not present, and several tests regarding p2p service discovery or p2p presence request are failing because there is no handler to process those action frames.

Isn't use_monitor irrelevant if device_ap_sme is set ?
What would be the correct way to fix this issue ?  at supplicant level or driver level ?


Best regards,
cedric

---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris, 
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20140929/8ee53007/attachment.htm>


More information about the HostAP mailing list