Roaming between 2 APs with WDS

Víctor Andrés victor at cymonline.com
Fri Oct 10 05:56:22 EDT 2014


Hi Avinash,

I'm using the firmware version 14.66.9.p192 
(http://git.marvell.com/?p=mwifiex-firmware.git;a=commit;h=633d06edab7a2b82efaa134ec5591cd20f9ac0a3) 
and testing the recent commit p52 version 
(http://git.marvell.com/?p=mwifiex-firmware.git;a=commit;h=3f45b8c4cc1eb1d102bc3486b19677332dd215ab), 
but I'm not sure of this last commit, becauseeven if it was posted more 
recent, it's a previous versionof the FW.

Yes, the roaming is working now. I'm trying to reduce the scanning 
timein order toscan only the channel in use or only for the known bssid. 
When the interface is scanning it isn't transmitting data, and what I 
need is a continuous flow of data.

Víctor

El 10/10/2014 10:55, Avinash Patil escribió:
> Hi Victor,
>
> What is SD8787 FW version you are using?  As I understand from your 
> last email, roaming is now working fine, right?
>
> Thanks,
> Avinash
>
> On Fri, Oct 10, 2014 at 12:38 PM, Víctor Andrés <victor at cymonline.com 
> <mailto:victor at cymonline.com>> wrote:
>
>     Hi Dan.
>     Thanks by your help.
>
>     I tested it in a different board and the signal level of the APs
>     were correct. At least, not all the same and with a value of -101.
>     May be a problem of the chip wifi of that board, I don't know. I
>     use the same antenna for the 2 tests, and the boards were in the
>     same position (more or less) for the 2 tests (with the same AP
>     locations). I'll continue with the tests. I don't understand how
>     can I connect with these APs that the wifi have detected with that
>     poor signal.
>
>     I've compiled Wpa-supplicant with bgscan option enabled and tested
>     in a different board, and now I have roaming between that 2 APs
>     (with bgscan:learn). Now I'm trying to reduce the searching time,
>     because when the wireless is searching network it can't transmit
>     data, isn't it?
>
>     Víctor
>
>
>     El 08/10/2014 19:33, Dan Williams escribió:
>
>         On Wed, 2014-10-08 at 12:35 +0200, Víctor Andrés Andrés wrote:
>
>         First, roaming works better with "bgscan" options enabled. 
>         This option
>         tells the supplicant to periodically scan looking for a better
>         AP.  If
>         scans don't happen (either through "bgscan" or manually via
>         the control
>         interface) the supplicant will stick with the current AP until the
>         connection is broken.  The only way the supplicant knows which
>         AP is
>         better is if a scan has taken place and it knows the RSSI of
>         each AP.
>
>         Second, it looks like the driver is broken for signal strength
>         reporting.  -100dBm signal level is quite awful, and the fact
>         that it
>         shows *all* APs at that level is pretty much a smoking gun. 
>         This is the
>         reason the supplicant won't switch APs even if you do trigger
>         a manual
>         scan, because no AP really has a better signal level than the
>         current
>         one.
>
>         (one other slight possibility: your antenna isn't connected
>         very well,
>         or isn't connected at all, and you're close to the APs...)
>
>         Dan
>
>
>     _______________________________________________
>     HostAP mailing list
>     HostAP at lists.shmoo.com <mailto:HostAP at lists.shmoo.com>
>     http://lists.shmoo.com/mailman/listinfo/hostap
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20141010/40c35980/attachment.htm>


More information about the HostAP mailing list