Roaming between 2 APs with WDS

Víctor Andrés victor at cymonline.com
Fri Oct 10 03:08:00 EDT 2014


Hi Dan.
Thanks by your help.

I tested it in a different board and the signal level of the APs were 
correct. At least, not all the same and with a value of -101. May be a 
problem of the chip wifi of that board, I don't know. I use the same 
antenna for the 2 tests, and the boards were in the same position (more 
or less) for the 2 tests (with the same AP locations). I'll continue 
with the tests. I don't understand how can I connect with these APs that 
the wifi have detected with that poor signal.

I've compiled Wpa-supplicant with bgscan option enabled and tested in a 
different board, and now I have roaming between that 2 APs (with 
bgscan:learn). Now I'm trying to reduce the searching time, because when 
the wireless is searching network it can't transmit data, isn't it?

Víctor


El 08/10/2014 19:33, Dan Williams escribió:
> On Wed, 2014-10-08 at 12:35 +0200, Víctor Andrés Andrés wrote:
>
> First, roaming works better with "bgscan" options enabled.  This option
> tells the supplicant to periodically scan looking for a better AP.  If
> scans don't happen (either through "bgscan" or manually via the control
> interface) the supplicant will stick with the current AP until the
> connection is broken.  The only way the supplicant knows which AP is
> better is if a scan has taken place and it knows the RSSI of each AP.
>
> Second, it looks like the driver is broken for signal strength
> reporting.  -100dBm signal level is quite awful, and the fact that it
> shows *all* APs at that level is pretty much a smoking gun.  This is the
> reason the supplicant won't switch APs even if you do trigger a manual
> scan, because no AP really has a better signal level than the current
> one.
>
> (one other slight possibility: your antenna isn't connected very well,
> or isn't connected at all, and you're close to the APs...)
>
> Dan
>



More information about the HostAP mailing list