[PATCH] nl80211: Fix compatibility with older version of libnl

Jouni Malinen j at w1.fi
Fri Oct 3 05:26:28 EDT 2014


On Wed, Oct 01, 2014 at 08:01:25AM +0200, Ilan Peer wrote:
> Commit "nl80211: Remove bridge FDB entry upon sta_remove()" used
> nl_sock and nl_socket_* functions which are not compatible with older
> versions of libnl. Fix this.

Thanks, applied.

> diff --git a/src/drivers/driver_nl80211.c b/src/drivers/driver_nl80211.c
>  #ifdef CONFIG_LIBNL3_ROUTE
>  	if (bss->added_if_into_bridge) {
> -		drv->rtnl_sk = nl_socket_alloc();
> +		drv->rtnl_sk = nl80211_handle_alloc();

With this part skipped due to build issues. While the end result is
somewhat ugly with rtnl_sk used with nl_socket_alloc() and
nl80211_handle_destroy(), this works and fixes a regression. Additional
cleanup can be done separately if needed.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list