signal strength monitoring not working with Centrino 2230N

mv2r76 at gmail.com mv2r76 at gmail.com
Fri Mar 28 13:30:40 EDT 2014


Hi, I'm having trouble getting bgscan to trigger a scan based on the signal
strength, and I'm wondering if anyone knows whether this should be working
or if it's unsupported for my setup.

The background scanning triggers just fine based on the timeouts, but I
would like it to trigger based on signal strength as well.  Here's some
info:

snippet of my wpa_supplicant.conf file:

bgscan="simple:simple:30:-45:300"


kernel version:

root at setnetgo:~# uname -a
Linux benchtest 3.4.13 #2 SMP PREEMPT Thu Mar 7 12:15:45 EST 2013 i686
GNU/Linux


lspci for wifi card, Centrino 2230n:

02:00.0 Network controller: Intel Corporation Device 088e (rev 24)
        Subsystem: Intel Corporation Device 4060
        Flags: bus master, fast devsel, latency 0, IRQ 50
        Memory at feafe000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number c4-85-08-ff-ff-03-7a-00
        Kernel driver in use: iwlwifi


iwlwifi messages in dmesg:

[    4.784373] iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
[    4.784381] iwlwifi 0000:02:00.0: pci_resource_base = f8390000
[    4.784388] iwlwifi 0000:02:00.0: HW Revision ID = 0x24
[    4.784498] iwlwifi 0000:02:00.0: irq 50 for MSI/MSI-X
[    4.857819] iwlwifi 0000:02:00.0: loaded firmware version 18.168.6.1
[    4.859344] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    4.859500] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    4.859589] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[    4.859676] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
[    4.859762] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_P2P disabled
[    4.859859] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R)
Advanced-N 6235 AGN, REV=0xB0
[    4.860131] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    4.875292] iwlwifi 0000:02:00.0: device EEPROM VER=0x756, CALIB=0x6
[    4.875398] iwlwifi 0000:02:00.0: Device SKU: 0x1F0
[    4.875485] iwlwifi 0000:02:00.0: Valid Tx ant: 0x3, Valid Rx ant: 0x3
[    4.875646] iwlwifi 0000:02:00.0: Tunable channels: 13 802.11bg, 24
802.11a channels


Here's what I see in the wpa_supplicant output:

1010024140.144677: bgscan simple: Signal strength threshold 30  Short
bgscan interval 30  Long bgscan interval 30
1010024140.144692: nl80211: Signal monitor threshold=30 hysteresis=4
1010024140.144786: bgscan simple: Failed to enable signal strength
monitoring
1010024140.144887: bgscan simple: Init scan interval: 30
1010024140.144897: bgscan: Initialized module 'simple' with parameters
'simple:30:-45:300'
1010024140.144990: nl80211: Associated on 5680 MHz
1010024140.144996: nl80211: Associated with 00:1c:f6:60:c9:8a
1010024140.145073: nl80211: Received scan results (16 BSSes)
1010024140.145100: nl80211: Scan results indicate BSS status with
00:1c:f6:60:c9:8a as associated


Does anyone have any pointers about how to make this work?

Thanks,

Matt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20140328/7d99c99f/attachment.htm>


More information about the HostAP mailing list